Website scanner for JavaScript vulnerabilities and security headers

https://keybase.io/encrypt

Full report

See on WebPageTest

Scan time

6/27/2020
7:37:32 PM

Webpage Security Score

F

A+ is the best score you can get.
Learn more about this score.
Fix JavaScript vulnerabilities in your project with Snyk (or try the free & open source CLI) Test and protect my website

JavaScript Libraries with vulnerabilities

The following list of JavaScript libraries were found to contain known and public security vulnerabilities.
We highly encourage you to upgrade to fixed versions as soon as possible.

Monitor my web application's project dependencies

Security headers

HTTP security headers enable better browser security policies.


Successfully detected the following security headers:
Vulnerable library Vulnerable version detected
  • M
bootstrap
3.3.5
  • M
bootstrap
3.3.5
  • M
jquery
1.11.3
  • L
moment
2.7.0
  • M
moment
2.7.0
  • M
moment
2.7.0

New vulnerabilities are continuously found for jQuery, lodash, Angular and other libraries.
Monitor these libraries to protect your web application.

Stay up to date on CVEs by connecting your project to Snyk to receive automated notifications & fixes.
The following security headers are missing from the website:
high severity

Content Security Policy

A computer security standard introduced to prevent cross-site scripting (XSS), clickjacking and other code injection attacks resulting from execution of malicious content in the trusted web page context