Docker circleci/node:dubnium-buster-browsers

Vulnerabilities

428 via 1896 paths

Dependencies

646

Source

Group 6 Copy Created with Sketch. Docker

Target OS

debian:10
Test your Docker Hub image against our market leading vulnerability database Sign up for free
Severity
  • 80
  • 68
  • 280
Status
  • 428
  • 0
  • 0
OS binaries
  • 426
  • 2

high severity

Integer Overflow or Wraparound

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. An integer overflow in function render() in tools/ddjvu via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

NULL Pointer Dereference

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

DjVuLibre 3.5.27 has a NULL pointer dereference in the function DJVU::filter_fv at IW44EncodeCodec.cpp.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Read

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. An out of bounds read in function DJVU::DataPool::has_data() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Write

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. A Stack overflow in function DJVU::DjVuDocument::get_djvu_file() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Write

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. An out of bounds write in function DJVU::filter_bv() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Write

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. A heap buffer overflow in function DJVU::GBitmap::decode() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Arbitrary Argument Injection

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters, relevant in non-default configurations that enable Delivery Status Notification (DSN). Certain uses of ORCPT= can place a newline into a spool header file, and indirectly allow unauthenticated remote attackers to execute arbitrary commands as root.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

CVE-2020-28015

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. Local users can alter the behavior of root processes because a recipient address can have a newline character.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

CVE-2020-28021

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. An authenticated remote SMTP client can insert newline characters into a spool file (which indirectly leads to remote code execution as root) via AUTH= in a MAIL FROM command.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Exposure of Resource to Wrong Sphere

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Exposure of File Descriptor to Unintended Control Sphere because rda_interpret uses a privileged pipe that lacks a close-on-exec flag.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Improper Initialization

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Initialization that can lead to recursion-based stack consumption or other consequences. This occurs because use of certain getc functions is mishandled when a client uses BDAT instead of DATA.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Improper Privilege Management

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root in the spool directory (owned by a non-root user), an attacker can write to a /var/spool/exim4/input spool header file, in which a crafted recipient address can indirectly lead to command execution.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow because get_stdinput allows unbounded reads that are accompanied by unbounded increases in a certain size variable. NOTE: exploitation may be impractical because of the execution time needed to overflow (multiple days).

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow in receive_add_recipient via an e-mail message with fifty million recipients. NOTE: remote exploitation may be difficult because of resource consumption.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Link Following

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root in the log directory (owned by a non-root user), a symlink or hard link attack allows overwriting critical root-owned files anywhere on the filesystem.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Restriction of Write Operations within the Bounds of a Memory Buffer. This occurs when processing name=value pairs within MAIL FROM and RCPT TO commands.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Buffer Underwrite that may result in unauthenticated remote attackers executing arbitrary commands, because smtp_ungetc was only intended to push back characters, but can actually push back non-character error codes such as EOF.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Out-of-bounds Read. smtp_setup_msg may disclose sensitive information from process memory to an unauthenticated SMTP client.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Out-of-bounds Read because pdkim_finish_bodyhash does not validate the relationship between sig->bodyhash.len and b->bh.len; thus, a crafted DKIM-Signature header might lead to a leak of sensitive information from process memory.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Out-of-bounds Write because the main function, while setuid root, copies the current working directory pathname into a buffer that is too small (on some common platforms).

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Heap-based Buffer Overflow in queue_run via two sender options: -R and -S. This may cause privilege escalation from exim to root.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Heap-based Buffer Overflow because it mishandles "-F '.('" on the command line, and thus may allow privilege escalation from any user to root. This occurs because of the interpretation of negative sizes in strncpy.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Use After Free

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Use After Free in smtp_reset in certain situations that may be common for builds with OpenSSL.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Information Exposure

  • Vulnerable module: gcc-8
  • Introduced through: gcc-8@8.3.0-6, gcc-8/cpp-8@8.3.0-6 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/cpp-8@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/g++-8@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/gcc-8-base@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libasan5@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libatomic1@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libcc1-0@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libgcc-8-dev@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libgcc1@1:8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libgomp1@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libitm1@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/liblsan0@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libmpx2@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libquadmath0@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libstdc++-8-dev@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libstdc++6@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libtsan0@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libubsan1@8.3.0-6

NVD Description

Note: Versions mentioned in the description apply to the upstream gcc-8 package.

stack_protect_prologue in cfgexpand.c and stack_protect_epilogue in function.c in GNU Compiler Collection (GCC) 4.1 through 8 (under certain circumstances) generate instruction sequences when targeting ARM targets that spill the address of the stack protector guard, which allows an attacker to bypass the protection of -fstack-protector, -fstack-protector-all, -fstack-protector-strong, and -fstack-protector-explicit against stack overflow by controlling what the stack canary is compared against.

Remediation

There is no fixed version for Debian:10 gcc-8.

References

high severity

Insufficient Entropy

  • Vulnerable module: gcc-8
  • Introduced through: gcc-8@8.3.0-6, gcc-8/cpp-8@8.3.0-6 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/cpp-8@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/g++-8@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/gcc-8-base@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libasan5@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libatomic1@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libcc1-0@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libgcc-8-dev@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libgcc1@1:8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libgomp1@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libitm1@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/liblsan0@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libmpx2@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libquadmath0@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libstdc++-8-dev@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libstdc++6@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libtsan0@8.3.0-6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gcc-8/libubsan1@8.3.0-6

NVD Description

Note: Versions mentioned in the description apply to the upstream gcc-8 package.

The POWER9 backend in GNU Compiler Collection (GCC) before version 10 could optimize multiple calls of the __builtin_darn intrinsic into a single call, thus reducing the entropy of the random number generator. This occurred because a volatile operation was not specified. For example, within a single execution of a program, the output of every __builtin_darn() call may be the same.

Remediation

There is no fixed version for Debian:10 gcc-8.

References

high severity

Out-of-bounds Read

  • Vulnerable module: giflib/libgif7
  • Introduced through: giflib/libgif7@5.1.4-3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* giflib/libgif7@5.1.4-3

NVD Description

Note: Versions mentioned in the description apply to the upstream giflib package.

An issue was discovered in giflib through 5.1.4. DumpScreen2RGB in gif2rgb.c has a heap-based buffer over-read.

Remediation

There is no fixed version for Debian:10 giflib.

References

high severity

Out-of-bounds Write

  • Vulnerable module: giflib/libgif7
  • Introduced through: giflib/libgif7@5.1.4-3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* giflib/libgif7@5.1.4-3

NVD Description

Note: Versions mentioned in the description apply to the upstream giflib package.

The DGifDecompressLine function in dgif_lib.c in GIFLIB (possibly version 3.0.x), as later shipped in cgif.c in sam2p 0.49.4, has a heap-based buffer overflow because a certain "Private->RunningCode - 2" array index is not checked. This will lead to a denial of service or possibly unspecified other impact.

Remediation

There is no fixed version for Debian:10 giflib.

References

high severity

Out-of-bounds Write

  • Vulnerable module: giflib/libgif7
  • Introduced through: giflib/libgif7@5.1.4-3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* giflib/libgif7@5.1.4-3

NVD Description

Note: Versions mentioned in the description apply to the upstream giflib package.

The DGifDecompressLine function in dgif_lib.c in GIFLIB (possibly version 3.0.x), as later shipped in cgif.c in sam2p 0.49.4, has a heap-based buffer overflow because a certain CrntCode array index is not checked. This will lead to a denial of service or possibly unspecified other impact.

Remediation

There is no fixed version for Debian:10 giflib.

References

high severity

Link Following

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2+deb10u3 and git/git-man@1:2.20.1-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* git@1:2.20.1-2+deb10u3
  • Introduced through: circleci/node:dubnium-buster-browsers@* git/git-man@1:2.20.1-2+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream git package.

Git is an open-source distributed revision control system. In affected versions of Git a specially crafted repository that contains symbolic links as well as files using a clean/smudge filter such as Git LFS, may cause just-checked out script to be executed while cloning onto a case-insensitive file system such as NTFS, HFS+ or APFS (i.e. the default file systems on Windows and macOS). Note that clean/smudge filters have to be configured for that. Git for Windows configures Git LFS by default, and is therefore vulnerable. The problem has been patched in the versions published on Tuesday, March 9th, 2021. As a workaound, if symbolic link support is disabled in Git (e.g. via git config --global core.symlinks false), the described attack won't work. Likewise, if no clean/smudge filters such as Git LFS are configured globally (i.e. before cloning), the attack is foiled. As always, it is best to avoid cloning repositories from untrusted sources. The earliest impacted version is 2.14.2. The fix versions are: 2.30.1, 2.29.3, 2.28.1, 2.27.1, 2.26.3, 2.25.5, 2.24.4, 2.23.4, 2.22.5, 2.21.4, 2.20.5, 2.19.6, 2.18.5, 2.17.62.17.6.

Remediation

There is no fixed version for Debian:10 git.

References

high severity

Incorrect Conversion between Numeric Types

  • Vulnerable module: glib2.0/libglib2.0-0
  • Introduced through: glib2.0/libglib2.0-0@2.58.3-2+deb10u2, glib2.0/libglib2.0-bin@2.58.3-2+deb10u2 and others
  • Fixed in: 2.58.3-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-0@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-bin@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-data@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-dev@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-dev-bin@2.58.3-2+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream glib2.0 package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in GNOME GLib before 2.66.7 and 2.67.x before 2.67.4. If g_byte_array_new_take() was called with a buffer of 4GB or more on a 64-bit platform, the length would be truncated modulo 2**32, causing unintended length truncation.

Remediation

Upgrade Debian:10 glib2.0 to version 2.58.3-2+deb10u3 or higher.

References

high severity

Incorrect Conversion between Numeric Types

  • Vulnerable module: glib2.0/libglib2.0-0
  • Introduced through: glib2.0/libglib2.0-0@2.58.3-2+deb10u2, glib2.0/libglib2.0-bin@2.58.3-2+deb10u2 and others
  • Fixed in: 2.58.3-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-0@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-bin@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-data@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-dev@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-dev-bin@2.58.3-2+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream glib2.0 package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in GNOME GLib before 2.66.6 and 2.67.x before 2.67.3. The function g_bytes_new has an integer overflow on 64-bit platforms due to an implicit cast from 64 bits to 32 bits. The overflow could potentially lead to memory corruption.

Remediation

Upgrade Debian:10 glib2.0 to version 2.58.3-2+deb10u3 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

An out-of-bounds write vulnerability was found in glibc before 2.31 when handling signal trampolines on PowerPC. Specifically, the backtrace function did not properly check the array bounds when storing the frame address, resulting in a denial of service or potential code execution. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Reachable Assertion

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid input sequences in the ISO-2022-JP-3 encoding, fails an assertion in the code path and aborts the program, potentially resulting in a denial of service.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Use After Free

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The mq_notify function in the GNU C Library (aka glibc) versions 2.32 and 2.33 has a use-after-free. It may use the notification thread attributes object (passed through its struct sigevent parameter) after it has been freed by the caller, leading to a denial of service (application crash) or possibly unspecified other impact.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Use After Free

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

A use-after-free vulnerability introduced in glibc upstream version 2.14 was found in the way the tilde expansion was carried out. Directory paths containing an initial tilde followed by a valid username were affected by this issue. A local attacker could exploit this flaw by creating a specially crafted path that, when processed by the glob function, would potentially lead to arbitrary code execution. This was fixed in version 2.32.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Out-of-bounds Write

  • Vulnerable module: gnutls28/libgnutls-dane0
  • Introduced through: gnutls28/libgnutls-dane0@3.6.7-4+deb10u6, gnutls28/libgnutls-openssl27@3.6.7-4+deb10u6 and others
  • Fixed in: 3.6.7-4+deb10u7

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls-dane0@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls-openssl27@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls28-dev@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls30@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutlsxx28@3.6.7-4+deb10u6

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in GnuTLS before 3.6.15. A server can trigger a NULL pointer dereference in a TLS 1.3 client if a no_renegotiation alert is sent with unexpected timing, and then an invalid second handshake occurs. The crash happens in the application's error handling path, where the gnutls_deinit function is called after detecting a handshake failure.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u7 or higher.

References

high severity

Use After Free

  • Vulnerable module: gnutls28/libgnutls-dane0
  • Introduced through: gnutls28/libgnutls-dane0@3.6.7-4+deb10u6, gnutls28/libgnutls-openssl27@3.6.7-4+deb10u6 and others
  • Fixed in: 3.6.7-4+deb10u7

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls-dane0@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls-openssl27@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls28-dev@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls30@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutlsxx28@3.6.7-4+deb10u6

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in gnutls. A use after free issue in client sending key_share extension may lead to memory corruption and other consequences.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u7 or higher.

References

high severity

Use After Free

  • Vulnerable module: gnutls28/libgnutls-dane0
  • Introduced through: gnutls28/libgnutls-dane0@3.6.7-4+deb10u6, gnutls28/libgnutls-openssl27@3.6.7-4+deb10u6 and others
  • Fixed in: 3.6.7-4+deb10u7

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls-dane0@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls-openssl27@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls28-dev@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutls30@3.6.7-4+deb10u6
  • Introduced through: circleci/node:dubnium-buster-browsers@* gnutls28/libgnutlsxx28@3.6.7-4+deb10u6

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in gnutls. A use after free issue in client_send_params in lib/ext/pre_shared_key.c may lead to memory corruption and other potential consequences.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u7 or higher.

References

high severity

Double Free

  • Vulnerable module: icu/icu-devtools
  • Introduced through: icu/icu-devtools@63.1-6+deb10u1, icu/libicu-dev@63.1-6+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* icu/icu-devtools@63.1-6+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* icu/libicu-dev@63.1-6+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* icu/libicu63@63.1-6+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream icu package.

Double free in ICU in Google Chrome prior to 91.0.4472.77 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Remediation

There is no fixed version for Debian:10 icu.

References

high severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in versions before 7.0.11 and before 6.9.12, where a division by zero in WaveImage() of MagickCore/visual-effects.c may trigger undefined behavior via a crafted image file submitted to an application using ImageMagick. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Information Exposure

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in versions before 7.0.11. A potential cipher leak when the calculate signatures in TransformSignature is possible. The highest threat from this vulnerability is to data confidentiality.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/statistic.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of values outside the range of type unsigned long. This would most likely lead to an impact to application availability, but could potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to 7.0.8-69.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in versions 7.0.11, where an integer overflow in WriteTHUMBNAILImage of coders/thumbnail.c may trigger undefined behavior via a crafted image file that is submitted by an attacker and processed by an application using ImageMagick. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

Stack-based buffer overflow and unconditional jump in ReadXPMImage in coders/xpm.c in ImageMagick 7.0.10-7.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/quantum-private.h. An attacker who submits a crafted file that is processed by ImageMagick could trigger a heap buffer overflow. This would most likely lead to an impact to application availability, but could potentially lead to an impact to data integrity as well. This flaw affects ImageMagick versions prior to 7.0.9-0.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

XML Injection

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

ImageMagick before 6.9.11-40 and 7.x before 7.0.10-40 mishandles the -authenticate option, which allows setting a password for password-protected PDF files. The user-controlled password was not properly escaped/sanitized and it was therefore possible to inject additional shell commands via coders/pdf.c.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Information Exposure

  • Vulnerable module: libgcrypt20
  • Introduced through: libgcrypt20@1.8.4-5
  • Fixed in: 1.8.4-5+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libgcrypt20@1.8.4-5

NVD Description

Note: Versions mentioned in the description apply to the upstream libgcrypt20 package. See Remediation section below for Debian:10 relevant versions.

Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. (There is also an interoperability problem because the selection of the k integer value does not properly consider the differences between basic ElGamal encryption and generalized ElGamal encryption.) This, for example, affects use of ElGamal in OpenPGP.

Remediation

Upgrade Debian:10 libgcrypt20 to version 1.8.4-5+deb10u1 or higher.

References

high severity

Improper Input Validation

  • Vulnerable module: libidn2/libidn2-0
  • Introduced through: libidn2/libidn2-0@2.0.5-1+deb10u1 and libidn2/libidn2-dev@2.0.5-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libidn2/libidn2-0@2.0.5-1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libidn2/libidn2-dev@2.0.5-1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libidn2 package.

GNU libidn2 before 2.2.0 fails to perform the roundtrip checks specified in RFC3490 Section 4.2 when converting A-labels to U-labels. This makes it possible in some circumstances for one domain to impersonate another. By creating a malicious domain that matches a target domain except for the inclusion of certain punycoded Unicode characters (that would be discarded when converted first to a Unicode label and then back to an ASCII label), arbitrary domains can be impersonated.

Remediation

There is no fixed version for Debian:10 libidn2.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libssh2/libssh2-1
  • Introduced through: libssh2/libssh2-1@1.8.0-2.1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libssh2/libssh2-1@1.8.0-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream libssh2 package.

In libssh2 before 1.9.0, kex_method_diffie_hellman_group_exchange_sha256_key_exchange in kex.c has an integer overflow that could lead to an out-of-bounds read in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server. This is related to an _libssh2_check_length mistake, and is different from the various issues fixed in 1.8.1, such as CVE-2019-3855.

Remediation

There is no fixed version for Debian:10 libssh2.

References

high severity

Improper Input Validation

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. When reading a file libwebp allocates an excessive amount of memory. The highest threat from this vulnerability is to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ApplyFilter. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ShiftBytes. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ChunkVerifyAndAssign. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function WebPMuxCreateInternal. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function WebPMuxCreateInternal. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ChunkAssignData. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. A heap-based buffer overflow in function WebPDecodeRGBInto is possible due to an invalid check for buffer size. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. A heap-based buffer overflow was found in PutLE16(). The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Use After Free

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. A use-after-free was found due to a thread being killed too early. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Use of Uninitialized Resource

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:dubnium-buster-browsers@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An unitialized variable is used in function ReadSymbol. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: libx11/libx11-6
  • Introduced through: libx11/libx11-6@2:1.6.7-1+deb10u1, libx11/libx11-data@2:1.6.7-1+deb10u1 and others
  • Fixed in: 2:1.6.7-1+deb10u2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libx11/libx11-6@2:1.6.7-1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libx11/libx11-data@2:1.6.7-1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libx11/libx11-dev@2:1.6.7-1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libx11/libx11-xcb1@2:1.6.7-1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libx11 package. See Remediation section below for Debian:10 relevant versions.

LookupCol.c in X.Org X through X11R7.7 and libX11 before 1.7.1 might allow remote attackers to execute arbitrary code. The libX11 XLookupColor request (intended for server-side color lookup) contains a flaw allowing a client to send color-name requests with a name longer than the maximum size allowed by the protocol (and also longer than the maximum packet size for normal-sized packets). The user-controlled data exceeding the maximum size is then interpreted by the server as additional X protocol requests and executed, e.g., to disable X server authorization completely. For example, if the victim encounters malicious terminal control sequences for color codes, then the attacker may be able to take full control of the running graphical session.

Remediation

Upgrade Debian:10 libx11 to version 2:1.6.7-1+deb10u2 or higher.

References

high severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: libxml2
  • Introduced through: libxml2@2.9.4+dfsg1-7+deb10u1 and libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2@2.9.4+dfsg1-7+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package.

parser.c in libxml2 before 2.9.5 does not prevent infinite recursion in parameter entities.

Remediation

There is no fixed version for Debian:10 libxml2.

References

high severity

Out-of-Bounds

  • Vulnerable module: libxml2
  • Introduced through: libxml2@2.9.4+dfsg1-7+deb10u1 and libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2@2.9.4+dfsg1-7+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

There is a flaw in the xml entity encoding functionality of libxml2 in versions before 2.9.11. An attacker who is able to supply a crafted file to be processed by an application linked with the affected functionality of libxml2 could trigger an out-of-bounds read. The most likely impact of this flaw is to application availability, with some potential impact to confidentiality and integrity if an attacker is able to use memory information to further exploit the application.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

high severity

Use After Free

  • Vulnerable module: libxml2
  • Introduced through: libxml2@2.9.4+dfsg1-7+deb10u1 and libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2@2.9.4+dfsg1-7+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

There's a flaw in libxml2's xmllint in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by xmllint could trigger a use-after-free. The greatest impact of this flaw is to confidentiality, integrity, and availability.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

high severity

Use After Free

  • Vulnerable module: libxml2
  • Introduced through: libxml2@2.9.4+dfsg1-7+deb10u1 and libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2@2.9.4+dfsg1-7+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

There's a flaw in libxml2 in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by an application linked with libxml2 could trigger a use-after-free. The greatest impact from this flaw is to confidentiality, integrity, and availability.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: lz4/liblz4-1
  • Introduced through: lz4/liblz4-1@1.8.3-1
  • Fixed in: 1.8.3-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* lz4/liblz4-1@1.8.3-1

NVD Description

Note: Versions mentioned in the description apply to the upstream lz4 package. See Remediation section below for Debian:10 relevant versions.

There's a flaw in lz4. An attacker who submits a crafted file to an application linked with lz4 may be able to trigger an integer overflow, leading to calling of memmove() on a negative size argument, causing an out-of-bounds write and/or a crash. The greatest impact of this flaw is to availability, with some potential impact to confidentiality and integrity as well.

Remediation

Upgrade Debian:10 lz4 to version 1.8.3-1+deb10u1 or higher.

References

high severity

OS Command Injection

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.27-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.27-0+deb10u1 and others
  • Fixed in: 1:10.3.29-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/libmariadb-dev@1:10.3.27-0+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/libmariadb-dev-compat@1:10.3.27-0+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/libmariadb3@1:10.3.27-0+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/mariadb-common@1:10.3.27-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

A remote code execution issue was discovered in MariaDB 10.2 before 10.2.37, 10.3 before 10.3.28, 10.4 before 10.4.18, and 10.5 before 10.5.9; Percona Server through 2021-03-03; and the wsrep patch through 2021-03-03 for MySQL. An untrusted search path leads to eval injection, in which a database SUPER user can execute OS commands after modifying wsrep_provider and wsrep_notify_cmd. NOTE: this does not affect an Oracle product.

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.29-0+deb10u1 or higher.

References

high severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: nettle/libhogweed4
  • Introduced through: nettle/libhogweed4@3.4.1-1, nettle/libnettle6@3.4.1-1 and others
  • Fixed in: 3.4.1-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* nettle/libhogweed4@3.4.1-1
  • Introduced through: circleci/node:dubnium-buster-browsers@* nettle/libnettle6@3.4.1-1
  • Introduced through: circleci/node:dubnium-buster-browsers@* nettle/nettle-dev@3.4.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream nettle package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in Nettle in versions before 3.7.2, where several Nettle signature verification functions (GOST DSA, EDDSA & ECDSA) result in the Elliptic Curve Cryptography point (ECC) multiply function being called with out-of-range scalers, possibly resulting in incorrect results. This flaw allows an attacker to force an invalid signature, causing an assertion failure or possible validation. The highest threat to this vulnerability is to confidentiality, integrity, as well as system availability.

Remediation

Upgrade Debian:10 nettle to version 3.4.1-1+deb10u1 or higher.

References

high severity
new

Out-of-bounds Read

  • Vulnerable module: node
  • Introduced through: node@10.24.1

Detailed paths

  • Introduced through: docker-image|circleci/node@dubnium-buster-browsers node@10.24.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Out-of-bounds Read in libuv's uv__idna_toascii() function which is used to convert strings to ASCII. This is called by Node's dns module's lookup() function and can lead to information disclosures or crashes.

Remediation

Upgrade node to version 16.4.1, 14.17.2, 12.22.2 or higher.

References

high severity
new

Privilege Escalation

  • Vulnerable module: node
  • Introduced through: node@10.24.1

Detailed paths

  • Introduced through: docker-image|circleci/node@dubnium-buster-browsers node@10.24.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Privilege Escalation under certain conditions on Windows platforms. More specifically, improper configuration of permissions in the installation directory allows an attacker to perform two different escalation attacks: PATH variable hijacking and DLL hijacking.

Remediation

Upgrade node to version 16.4.1, 14.17.2, 12.22.2 or higher.

References

high severity

Allocation of Resources Without Limits or Throttling

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* nss/libnss3@2:3.42.1-1+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

A flaw was found in the way NSS handled CCS (ChangeCipherSpec) messages in TLS 1.3. This flaw allows a remote attacker to send multiple CCS messages, causing a denial of service for servers compiled with the NSS library. The highest threat from this vulnerability is to system availability. This flaw affects NSS versions before 3.58.

Remediation

There is no fixed version for Debian:10 nss.

References

high severity

Out-of-bounds Read

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* nss/libnss3@2:3.42.1-1+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

A flaw was found in the way CHACHA20-POLY1305 was implemented in NSS in versions before 3.55. When using multi-part Chacha20, it could cause out-of-bounds reads. This issue was fixed by explicitly disabling multi-part ChaCha20 (which was not functioning correctly) and strictly enforcing tag length. The highest threat from this vulnerability is to confidentiality and system availability.

Remediation

There is no fixed version for Debian:10 nss.

References

high severity
new

CVE-2021-2388

  • Vulnerable module: openjdk-11/openjdk-11-jdk
  • Introduced through: openjdk-11/openjdk-11-jdk@11.0.9.1+1-1~deb10u2, openjdk-11/openjdk-11-jdk-headless@11.0.9.1+1-1~deb10u2 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jdk@11.0.9.1+1-1~deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jdk-headless@11.0.9.1+1-1~deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jre@11.0.9.1+1-1~deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jre-headless@11.0.9.1+1-1~deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openjdk-11 package.

Vulnerability in the Java SE, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Hotspot). Supported versions that are affected are Java SE: 8u291, 11.0.11, 16.0.1; Oracle GraalVM Enterprise Edition: 20.3.2 and 21.1.0. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Oracle GraalVM Enterprise Edition. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in takeover of Java SE, Oracle GraalVM Enterprise Edition. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.1 Base Score 7.5 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H).

Remediation

There is no fixed version for Debian:10 openjdk-11.

References

high severity

Out-of-bounds Read

  • Vulnerable module: pcre2/libpcre2-8-0
  • Introduced through: pcre2/libpcre2-8-0@10.32-5

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* pcre2/libpcre2-8-0@10.32-5

NVD Description

Note: Versions mentioned in the description apply to the upstream pcre2 package.

An out-of-bounds read was discovered in PCRE before 10.34 when the pattern \X is JIT compiled and used to match specially crafted subjects in non-UTF mode. Applications that use PCRE to parse untrusted input may be vulnerable to this flaw, which would allow an attacker to crash the application. The flaw occurs in do_extuni_no_utf in pcre2_jit_compile.c.

Remediation

There is no fixed version for Debian:10 pcre2.

References

high severity

Out-of-Bounds

  • Vulnerable module: postgresql-11/libpq-dev
  • Introduced through: postgresql-11/libpq-dev@11.11-0+deb10u1 and postgresql-11/libpq5@11.11-0+deb10u1
  • Fixed in: 11.12-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* postgresql-11/libpq-dev@11.11-0+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* postgresql-11/libpq5@11.11-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream postgresql-11 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 postgresql-11 to version 11.12-0+deb10u1 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: python2.7
  • Introduced through: python2.7@2.7.16-2+deb10u1, python2.7/libpython2.7@2.7.16-2+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* python2.7@2.7.16-2+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* python2.7/libpython2.7@2.7.16-2+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* python2.7/libpython2.7-minimal@2.7.16-2+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* python2.7/libpython2.7-stdlib@2.7.16-2+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* python2.7/python2.7-minimal@2.7.16-2+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream python2.7 package.

Python 3.x through 3.9.1 has a buffer overflow in PyCArg_repr in _ctypes/callproc.c, which may lead to remote code execution in certain Python applications that accept floating-point numbers as untrusted input, as demonstrated by a 1e300 argument to c_double.from_param. This occurs because sprintf is used unsafely.

Remediation

There is no fixed version for Debian:10 python2.7.

References

high severity

CVE-2019-19603

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.27.2-3+deb10u1 and sqlite3/libsqlite3-dev@3.27.2-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* sqlite3/libsqlite3-0@3.27.2-3+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* sqlite3/libsqlite3-dev@3.27.2-3+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package.

SQLite 3.30.1 mishandles certain SELECT statements with a nonexistent VIEW, leading to an application crash.

Remediation

There is no fixed version for Debian:10 sqlite3.

References

high severity

Incorrect Privilege Assignment

  • Vulnerable module: systemd
  • Introduced through: systemd@241-7~deb10u7, systemd/libnss-systemd@241-7~deb10u7 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd@241-7~deb10u7
  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd/libnss-systemd@241-7~deb10u7
  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd/libpam-systemd@241-7~deb10u7
  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd/libsystemd0@241-7~deb10u7
  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd/libudev1@241-7~deb10u7
  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd/systemd-sysv@241-7~deb10u7

NVD Description

Note: Versions mentioned in the description apply to the upstream systemd package.

It was discovered that a systemd service that uses DynamicUser property can create a SUID/SGID binary that would be allowed to run as the transient service UID/GID even after the service is terminated. A local attacker may use this flaw to access resources that will be owned by a potentially different service in the future, when the UID/GID will be recycled.

Remediation

There is no fixed version for Debian:10 systemd.

References

high severity

Privilege Chaining

  • Vulnerable module: systemd
  • Introduced through: systemd@241-7~deb10u7, systemd/libnss-systemd@241-7~deb10u7 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd@241-7~deb10u7
  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd/libnss-systemd@241-7~deb10u7
  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd/libpam-systemd@241-7~deb10u7
  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd/libsystemd0@241-7~deb10u7
  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd/libudev1@241-7~deb10u7
  • Introduced through: circleci/node:dubnium-buster-browsers@* systemd/systemd-sysv@241-7~deb10u7

NVD Description

Note: Versions mentioned in the description apply to the upstream systemd package.

It was discovered that a systemd service that uses DynamicUser property can get new privileges through the execution of SUID binaries, which would allow to create binaries owned by the service transient group with the setgid bit set. A local attacker may use this flaw to access resources that will be owned by a potentially different service in the future, when the GID will be recycled.

Remediation

There is no fixed version for Debian:10 systemd.

References

high severity

Integer Underflow

  • Vulnerable module: xorg-server/xserver-common
  • Introduced through: xorg-server/xserver-common@2:1.20.4-1+deb10u2 and xorg-server/xvfb@2:1.20.4-1+deb10u2
  • Fixed in: 2:1.20.4-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* xorg-server/xserver-common@2:1.20.4-1+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* xorg-server/xvfb@2:1.20.4-1+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream xorg-server package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in xorg-x11-server in versions before 1.20.11. An integer underflow can occur in xserver which can lead to a local privilege escalation. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 xorg-server to version 2:1.20.4-1+deb10u3 or higher.

References

medium severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: avahi/libavahi-client3
  • Introduced through: avahi/libavahi-client3@0.7-4+deb10u1, avahi/libavahi-common-data@0.7-4+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* avahi/libavahi-client3@0.7-4+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* avahi/libavahi-common-data@0.7-4+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* avahi/libavahi-common3@0.7-4+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream avahi package.

A flaw was found in avahi in versions 0.6 up to 0.8. The event used to signal the termination of the client connection on the avahi Unix socket is not correctly handled in the client_work function, allowing a local attacker to trigger an infinite loop. The highest threat from this vulnerability is to the availability of the avahi service, which becomes unresponsive after this flaw is triggered.

Remediation

There is no fixed version for Debian:10 avahi.

References

medium severity

Improper Input Validation

  • Vulnerable module: cups/libcups2
  • Introduced through: cups/libcups2@2.2.10-6+deb10u4

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* cups/libcups2@2.2.10-6+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream cups package.

An input validation issue was addressed with improved memory handling. This issue is fixed in macOS Big Sur 11.1, Security Update 2020-001 Catalina, Security Update 2020-007 Mojave. A malicious application may be able to read restricted memory.

Remediation

There is no fixed version for Debian:10 cups.

References

medium severity
new

Out-of-bounds Write

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

An out-of-bounds write vulnerability was found in DjVuLibre in DJVU::DjVuTXT::decode() in DjVuText.cpp via a crafted djvu file which may lead to crash and segmentation fault. This flaw affects DjVuLibre versions prior to 3.5.28.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

medium severity

CVE-2020-28014

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u5, exim4/exim4-config@4.92-8+deb10u5 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-base@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-config@4.92-8+deb10u5
  • Introduced through: circleci/node:dubnium-buster-browsers@* exim4/exim4-daemon-light@4.92-8+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. The -oP option is available to the exim user, and allows a denial of service because root-owned files can be overwritten.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

medium severity

Divide By Zero

  • Vulnerable module: giflib/libgif7
  • Introduced through: giflib/libgif7@5.1.4-3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* giflib/libgif7@5.1.4-3

NVD Description

Note: Versions mentioned in the description apply to the upstream giflib package.

In GIFLIB before 2019-02-16, a malformed GIF file triggers a divide-by-zero exception in the decoder function DGifSlurp in dgif_lib.c if the height field of the ImageSize data structure is equal to zero.

Remediation

There is no fixed version for Debian:10 giflib.

References

medium severity

Link Following

  • Vulnerable module: glib2.0/libglib2.0-0
  • Introduced through: glib2.0/libglib2.0-0@2.58.3-2+deb10u2, glib2.0/libglib2.0-bin@2.58.3-2+deb10u2 and others
  • Fixed in: 2.58.3-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-0@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-bin@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-data@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-dev@2.58.3-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* glib2.0/libglib2.0-dev-bin@2.58.3-2+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream glib2.0 package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in GNOME GLib before 2.66.8. When g_file_replace() is used with G_FILE_CREATE_REPLACE_DESTINATION to replace a path that is a dangling symlink, it incorrectly also creates the target of the symlink as an empty file, which could conceivably have security relevance if the symlink is attacker-controlled. (If the path is a symlink to a file that already exists, then the contents of that file correctly remain unchanged.)

Remediation

Upgrade Debian:10 glib2.0 to version 2.58.3-2+deb10u3 or higher.

References

medium severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid multi-byte input sequences in IBM1364, IBM1371, IBM1388, IBM1390, and IBM1399 encodings, fails to advance the input state, which could lead to an infinite loop in applications, resulting in a denial of service, a different vulnerability from CVE-2016-10228.

Remediation

There is no fixed version for Debian:10 glibc.

References

medium severity

Out-of-Bounds

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The GNU C Library (aka glibc or libc6) before 2.32 could overflow an on-stack buffer during range reduction if an input to an 80-bit long double function contains a non-canonical bit pattern, a seen when passing a 0x5d414141414141410000 value to sinl on x86 targets. This is related to sysdeps/ieee754/ldbl-96/e_rem_pio2l.c.

Remediation

There is no fixed version for Debian:10 glibc.

References

medium severity

Out-of-bounds Read

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:dubnium-buster-browsers@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv feature in the GNU C Library (aka glibc or libc6) through 2.32, when processing invalid multi-byte input sequences in the EUC-KR encoding, may have a buffer over-read.

Remediation

There is no fixed version for Debian:10 glibc.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/colorspace-private.h and MagickCore/quantum.h. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of values outside the range of type unsigned char and math division by zero. This would most likely lead to an impact to application availability, but could potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

In ParseMetaGeometry() of MagickCore/geometry.c, image height and width calculations can lead to divide-by-zero conditions which also lead to undefined behavior. This flaw can be triggered by a crafted input file processed by ImageMagick and could impact application availability. The patch uses multiplication in addition to the function PerceptibleReciprocal() in order to prevent such divide-by-zero conditions. This flaw affects ImageMagick versions prior to 7.0.9-0.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

In GammaImage() of /MagickCore/enhance.c, depending on the gamma value, it's possible to trigger a divide-by-zero condition when a crafted input file is processed by ImageMagick. This could lead to an impact to application availability. The patch uses the PerceptibleReciprocal() to prevent the divide-by-zero from occurring. This flaw affects ImageMagick versions prior to ImageMagick 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A divide-by-zero flaw was found in ImageMagick 6.9.11-57 and 7.0.10-57 in gem.c. This flaw allows an attacker who submits a crafted file that is processed by ImageMagick to trigger undefined behavior through a division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in coders/jp2.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in coders/webp.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/resample.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/visual-effects.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/resize.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in coders/hdr.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of values outside the range of type unsigned char. This would most likely lead to an impact to application availability, but could potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to ImageMagick 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

In CatromWeights(), MeshInterpolate(), InterpolatePixelChannel(), InterpolatePixelChannels(), and InterpolatePixelInfo(), which are all functions in /MagickCore/pixel.c, there were multiple unconstrained pixel offset calculations which were being used with the floor() function. These calculations produced undefined behavior in the form of out-of-range and integer overflows, as identified by UndefinedBehaviorSanitizer. These instances of undefined behavior could be triggered by an attacker who is able to supply a crafted input file to be processed by ImageMagick. These issues could impact application availability or potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to 7.0.9-0.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

Due to a missing check for 0 value of replace_extent, it is possible for offset p to overflow in SubstituteString(), causing potential impact to application availability. This could be triggered by a crafted input file that is processed by ImageMagick. This flaw affects ImageMagick versions prior to 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Out-of-bounds Read

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

WriteOnePNGImage() from coders/png.c (the PNG coder) has a for loop with an improper exit condition that can allow an out-of-bounds READ via heap-buffer-overflow. This occurs because it is possible for the colormap to have less than 256 valid values but the loop condition will loop 256 times, attempting to pass invalid colormap data to the event logger. The patch replaces the hardcoded 256 value with a call to MagickMin() to ensure the proper value is used. This could impact application availability when a specially crafted input file is processed by ImageMagick. This flaw affects ImageMagick versions prior to 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Out-of-bounds Read

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

The PALM image coder at coders/palm.c makes an improper call to AcquireQuantumMemory() in routine WritePALMImage() because it needs to be offset by 256. This can cause a out-of-bounds read later on in the routine. The patch adds 256 to bytes_per_row in the call to AcquireQuantumMemory(). This could cause impact to reliability. This flaw affects ImageMagick versions prior to 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

In WriteOnePNGImage() of the PNG coder at coders/png.c, an improper call to AcquireVirtualMemory() and memset() allows for an out-of-bounds write later when PopShortPixel() from MagickCore/quantum-private.h is called. The patch fixes the calls by adding 256 to rowbytes. An attacker who is able to supply a specially crafted image could affect availability with a low impact to data integrity. This flaw affects ImageMagick versions prior to 6.9.10-68 and 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Use After Free

  • Vulnerable module: iproute2
  • Introduced through: iproute2@4.20.0-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* iproute2@4.20.0-2+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream iproute2 package.

iproute2 before 5.1.0 has a use-after-free in get_netnsid_from_name in ip/ipnetns.c. NOTE: security relevance may be limited to certain uses of setuid that, although not a default, are sometimes a configuration option offered to end users. Even when setuid is used, other factors (such as C library configuration) may block exploitability.

Remediation

There is no fixed version for Debian:10 iproute2.

References

medium severity

Race Condition

  • Vulnerable module: libgcrypt20
  • Introduced through: libgcrypt20@1.8.4-5

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libgcrypt20@1.8.4-5

NVD Description

Note: Versions mentioned in the description apply to the upstream libgcrypt20 package.

It was discovered that there was a ECDSA timing attack in the libgcrypt20 cryptographic library. Version affected: 1.8.4-5, 1.7.6-2+deb9u3, and 1.6.3-2+deb8u4. Versions fixed: 1.8.5-2 and 1.6.3-2+deb8u7.

Remediation

There is no fixed version for Debian:10 libgcrypt20.

References

medium severity

Resource Exhaustion

  • Vulnerable module: librsvg/gir1.2-rsvg-2.0
  • Introduced through: librsvg/gir1.2-rsvg-2.0@2.44.10-2.1, librsvg/librsvg2-2@2.44.10-2.1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* librsvg/gir1.2-rsvg-2.0@2.44.10-2.1
  • Introduced through: circleci/node:dubnium-buster-browsers@* librsvg/librsvg2-2@2.44.10-2.1
  • Introduced through: circleci/node:dubnium-buster-browsers@* librsvg/librsvg2-common@2.44.10-2.1
  • Introduced through: circleci/node:dubnium-buster-browsers@* librsvg/librsvg2-dev@2.44.10-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream librsvg package.

In xml.rs in GNOME librsvg before 2.46.2, a crafted SVG file with nested patterns can cause denial of service when passed to the library for processing. The attacker constructs pattern elements so that the number of final rendered objects grows exponentially.

Remediation

There is no fixed version for Debian:10 librsvg.

References

medium severity
new

Out-of-bounds Read

  • Vulnerable module: libsepol/libsepol1
  • Introduced through: libsepol/libsepol1@2.8-1 and libsepol/libsepol1-dev@2.8-1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libsepol/libsepol1@2.8-1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libsepol/libsepol1-dev@2.8-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libsepol package.

The CIL compiler in SELinux 3.2 has a heap-based buffer over-read in ebitmap_match_any (called indirectly from cil_check_neverallow). NOTE: bad0a746e9f4cf260dedba5828d9645d50176aac is cited in the OSV "fixed" field but does not have a code change.

Remediation

There is no fixed version for Debian:10 libsepol.

References

medium severity
new

Use After Free

  • Vulnerable module: libsepol/libsepol1
  • Introduced through: libsepol/libsepol1@2.8-1 and libsepol/libsepol1-dev@2.8-1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libsepol/libsepol1@2.8-1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libsepol/libsepol1-dev@2.8-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libsepol package.

The CIL compiler in SELinux 3.2 has a use-after-free in __cil_verify_classperms (called from __verify_map_perm_classperms and hashtab_map).

Remediation

There is no fixed version for Debian:10 libsepol.

References

medium severity
new

Use After Free

  • Vulnerable module: libsepol/libsepol1
  • Introduced through: libsepol/libsepol1@2.8-1 and libsepol/libsepol1-dev@2.8-1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libsepol/libsepol1@2.8-1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libsepol/libsepol1-dev@2.8-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libsepol package.

The CIL compiler in SELinux 3.2 has a use-after-free in __cil_verify_classperms (called from __cil_verify_classpermission and __cil_pre_verify_helper).

Remediation

There is no fixed version for Debian:10 libsepol.

References

medium severity
new

Use After Free

  • Vulnerable module: libsepol/libsepol1
  • Introduced through: libsepol/libsepol1@2.8-1 and libsepol/libsepol1-dev@2.8-1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libsepol/libsepol1@2.8-1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libsepol/libsepol1-dev@2.8-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libsepol package.

The CIL compiler in SELinux 3.2 has a use-after-free in cil_reset_classpermission (called from cil_reset_classperms_set and cil_reset_classperms_list).

Remediation

There is no fixed version for Debian:10 libsepol.

References

medium severity

Improper Restriction of Recursive Entity References in DTDs ('XML Entity Expansion')

  • Vulnerable module: libxml2
  • Introduced through: libxml2@2.9.4+dfsg1-7+deb10u1 and libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2@2.9.4+dfsg1-7+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libxml2. Exponential entity expansion attack its possible bypassing all existing protection mechanisms and leading to denial of service.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

medium severity

NULL Pointer Dereference

  • Vulnerable module: libxml2
  • Introduced through: libxml2@2.9.4+dfsg1-7+deb10u1 and libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2@2.9.4+dfsg1-7+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

A vulnerability found in libxml2 in versions before 2.9.11 shows that it did not propagate errors while parsing XML mixed content, causing a NULL dereference. If an untrusted XML document was parsed in recovery mode and post-validated, the flaw could be used to crash the application. The highest threat from this vulnerability is to system availability.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

medium severity

Out-of-bounds Read

  • Vulnerable module: libxml2
  • Introduced through: libxml2@2.9.4+dfsg1-7+deb10u1 and libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2@2.9.4+dfsg1-7+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

GNOME project libxml2 v2.9.10 has a global buffer over-read vulnerability in xmlEncodeEntitiesInternal at libxml2/entities.c. The issue has been fixed in commit 50f06b3e.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

medium severity

XML External Entity (XXE) Injection

  • Vulnerable module: libxml2
  • Introduced through: libxml2@2.9.4+dfsg1-7+deb10u1 and libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2@2.9.4+dfsg1-7+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* libxml2/libxml2-dev@2.9.4+dfsg1-7+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package.

libxml2 2.9.4 and earlier, as used in XMLSec 1.2.23 and earlier and other products, does not offer a flag directly indicating that the current document may be read but other files may not be opened, which makes it easier for remote attackers to conduct XML External Entity (XXE) attacks via a crafted document.

Remediation

There is no fixed version for Debian:10 libxml2.

References

medium severity

CVE-2021-2154

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.27-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.27-0+deb10u1 and others
  • Fixed in: 1:10.3.29-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/libmariadb-dev@1:10.3.27-0+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/libmariadb-dev-compat@1:10.3.27-0+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/libmariadb3@1:10.3.27-0+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/mariadb-common@1:10.3.27-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: DML). Supported versions that are affected are 5.7.33 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.29-0+deb10u1 or higher.

References

medium severity

CVE-2021-2166

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.27-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.27-0+deb10u1 and others
  • Fixed in: 1:10.3.29-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/libmariadb-dev@1:10.3.27-0+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/libmariadb-dev-compat@1:10.3.27-0+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/libmariadb3@1:10.3.27-0+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* mariadb-10.3/mariadb-common@1:10.3.27-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: DML). Supported versions that are affected are 5.7.33 and prior and 8.0.23 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.29-0+deb10u1 or higher.

References

medium severity

CVE-2020-6829

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* nss/libnss3@2:3.42.1-1+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

When performing EC scalar point multiplication, the wNAF point multiplication algorithm was used; which leaked partial information about the nonce used during signature generation. Given an electro-magnetic trace of a few signature generations, the private key could have been computed. This vulnerability affects Firefox < 80 and Firefox for Android < 80.

Remediation

There is no fixed version for Debian:10 nss.

References

medium severity

Information Exposure

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* nss/libnss3@2:3.42.1-1+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

When converting coordinates from projective to affine, the modular inversion was not performed in constant time, resulting in a possible timing-based side channel attack. This vulnerability affects Firefox < 80 and Firefox for Android < 80.

Remediation

There is no fixed version for Debian:10 nss.

References

medium severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* nss/libnss3@2:3.42.1-1+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

During ECDSA signature generation, padding applied in the nonce designed to ensure constant-time scalar multiplication was removed, resulting in variable-time execution dependent on secret data. This vulnerability affects Firefox < 80 and Firefox for Android < 80.

Remediation

There is no fixed version for Debian:10 nss.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

A flaw was found in OpenEXR's B44 uncompression functionality in versions before 3.0.0-beta. An attacker who is able to submit a crafted file to OpenEXR could trigger shift overflows, potentially affecting application availability.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

There's a flaw in OpenEXR in versions before 3.0.0-beta. A crafted input file that is processed by OpenEXR could cause a shift overflow in the FastHufDecoder, potentially leading to problems with application availability.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

There is a flaw in OpenEXR in versions before 3.0.0-beta. An attacker who can submit a crafted file to be processed by OpenEXR could cause an integer overflow, potentially leading to problems with application availability.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

An integer overflow leading to a heap-buffer overflow was found in the DwaCompressor of OpenEXR in versions before 3.0.1. An attacker could use this flaw to crash an application compiled with OpenEXR.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

Integer Underflow

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

An integer overflow leading to a heap-buffer overflow was found in the DwaCompressor of OpenEXR in versions before 3.0.1. An attacker could use this flaw to crash an application compiled with OpenEXR. This is a different flaw from CVE-2021-23215.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

NULL Pointer Dereference

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

A Null Pointer Deference issue exists in Academy Software Foundation OpenEXR 2.3.0 in generatePreview in makePreview.cpp that can cause a denial of service via a crafted EXR file.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

NULL Pointer Dereference

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

A flaw was found in OpenEXR in versions before 3.0.0-beta. A crafted input file supplied by an attacker, that is processed by the Dwa decompression functionality of OpenEXR's IlmImf library, could cause a NULL pointer dereference. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

Out-of-Bounds

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

There's a flaw in OpenEXR's ImfDeepScanLineInputFile functionality in versions prior to 3.0.5. An attacker who is able to submit a crafted file to an application linked with OpenEXR could cause an out-of-bounds read. The greatest risk from this flaw is to application availability.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

Out-of-bounds Read

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

There's a flaw in OpenEXR's deep tile sample size calculations in versions before 3.0.0-beta. An attacker who is able to submit a crafted file to be processed by OpenEXR could trigger an integer overflow, subsequently leading to an out-of-bounds read. The greatest risk of this flaw is to application availability.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

A heap-based buffer overflow vulnerability exists in Academy Software Foundation OpenEXR 2.3.0 in chunkOffsetReconstruction in ImfMultiPartInputFile.cpp that can cause a denial of service via a crafted EXR file.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

A head-based buffer overflow exists in Academy Software Foundation OpenEXR 2.3.0 in writeTileData in ImfTiledOutputFile.cpp that can cause a denial of service via a crafted EXR file.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

Resource Exhaustion

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

There's a flaw in OpenEXR's Scanline API functionality in versions before 3.0.0-beta. An attacker who is able to submit a crafted file to be processed by OpenEXR could trigger excessive consumption of memory, resulting in an impact to system availability.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

Resource Exhaustion

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

There's a flaw in OpenEXR's scanline input file functionality in versions before 3.0.0-beta. An attacker able to submit a crafted file to be processed by OpenEXR could consume excessive system memory. The greatest impact of this flaw is to system availability.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

CVE-2021-2163

  • Vulnerable module: openjdk-11/openjdk-11-jdk
  • Introduced through: openjdk-11/openjdk-11-jdk@11.0.9.1+1-1~deb10u2, openjdk-11/openjdk-11-jdk-headless@11.0.9.1+1-1~deb10u2 and others
  • Fixed in: 11.0.11+9-1~deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jdk@11.0.9.1+1-1~deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jdk-headless@11.0.9.1+1-1~deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jre@11.0.9.1+1-1~deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jre-headless@11.0.9.1+1-1~deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openjdk-11 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the Java SE, Java SE Embedded, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 7u291, 8u281, 11.0.10, 16; Java SE Embedded: 8u281; Oracle GraalVM Enterprise Edition: 19.3.5, 20.3.1.2 and 21.0.0.2. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded, Oracle GraalVM Enterprise Edition. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all Java SE, Java SE Embedded, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability applies to Java deployments that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. CVSS 3.1 Base Score 5.3 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N).

Remediation

Upgrade Debian:10 openjdk-11 to version 11.0.11+9-1~deb10u1 or higher.

References

medium severity
new

CVE-2021-2369

  • Vulnerable module: openjdk-11/openjdk-11-jdk
  • Introduced through: openjdk-11/openjdk-11-jdk@11.0.9.1+1-1~deb10u2, openjdk-11/openjdk-11-jdk-headless@11.0.9.1+1-1~deb10u2 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jdk@11.0.9.1+1-1~deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jdk-headless@11.0.9.1+1-1~deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jre@11.0.9.1+1-1~deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* openjdk-11/openjdk-11-jre-headless@11.0.9.1+1-1~deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openjdk-11 package.

Vulnerability in the Java SE, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Library). Supported versions that are affected are Java SE: 7u301, 8u291, 11.0.11, 16.0.1; Oracle GraalVM Enterprise Edition: 20.3.2 and 21.1.0. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Oracle GraalVM Enterprise Edition. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Java SE, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.1 Base Score 4.3 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N).

Remediation

There is no fixed version for Debian:10 openjdk-11.

References

medium severity

Excessive Iteration

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2+deb10u2 and openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openjpeg2/libopenjp2-7@2.3.0-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package.

In OpenJPEG 2.3.1, there is excessive iteration in the opj_t1_encode_cblks function of openjp2/t1.c. Remote attackers could leverage this vulnerability to cause a denial of service via a crafted bmp file. This issue is similar to CVE-2018-6616.

Remediation

There is no fixed version for Debian:10 openjpeg2.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2+deb10u2 and openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* openjpeg2/libopenjp2-7@2.3.0-2+deb10u2
  • Introduced through: circleci/node:dubnium-buster-browsers@* openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package.

Integer Overflow in OpenJPEG v2.4.0 allows remote attackers to crash the application, causing a Denial of Service (DoS). This occurs when the attacker uses the command line option "-ImgDir" on a directory that contains 1048576 files.

Remediation

There is no fixed version for Debian:10 openjpeg2.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: pcre3/libpcre16-3
  • Introduced through: pcre3/libpcre16-3@2:8.39-12, pcre3/libpcre3@2:8.39-12 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* pcre3/libpcre16-3@2:8.39-12
  • Introduced through: circleci/node:dubnium-buster-browsers@* pcre3/libpcre3@2:8.39-12
  • Introduced through: circleci/node:dubnium-buster-browsers@* pcre3/libpcre3-dev@2:8.39-12
  • Introduced through: circleci/node:dubnium-buster-browsers@* pcre3/libpcre32-3@2:8.39-12
  • Introduced through: circleci/node:dubnium-buster-browsers@* pcre3/libpcrecpp0v5@2:8.39-12

NVD Description

Note: Versions mentioned in the description apply to the upstream pcre3 package.

libpcre in PCRE before 8.44 allows an integer overflow via a large number after a (?C substring.

Remediation

There is no fixed version for Debian:10 pcre3.

References

medium severity

HTTP Request Smuggling

  • Vulnerable module: python2.7
  • Introduced through: python2.7@2.7.16-2+deb10u1, python2.7/libpython2.7@2.7.16-2+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* python2.7@2.7.16-2+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* python2.7/libpython2.7@2.7.16-2+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* python2.7/libpython2.7-minimal@2.7.16-2+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* python2.7/libpython2.7-stdlib@2.7.16-2+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* python2.7/python2.7-minimal@2.7.16-2+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream python2.7 package.

The package python/cpython from 0 and before 3.6.13, from 3.7.0 and before 3.7.10, from 3.8.0 and before 3.8.8, from 3.9.0 and before 3.9.2 are vulnerable to Web Cache Poisoning via urllib.parse.parse_qsl and urllib.parse.parse_qs by using a vector called parameter cloaking. When the attacker can separate query parameters using a semicolon (;), they can cause a difference in the interpretation of the request between the proxy (running with default configuration) and the server. This can result in malicious requests being cached as completely safe ones, as the proxy would usually not see the semicolon as a separator, and therefore would not include it in a cache key of an unkeyed parameter.

Remediation

There is no fixed version for Debian:10 python2.7.

References

medium severity

HTTP Request Smuggling

  • Vulnerable module: python3.7
  • Introduced through: python3.7@3.7.3-2+deb10u3, python3.7/libpython3.7-minimal@3.7.3-2+deb10u3 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* python3.7@3.7.3-2+deb10u3
  • Introduced through: circleci/node:dubnium-buster-browsers@* python3.7/libpython3.7-minimal@3.7.3-2+deb10u3
  • Introduced through: circleci/node:dubnium-buster-browsers@* python3.7/libpython3.7-stdlib@3.7.3-2+deb10u3
  • Introduced through: circleci/node:dubnium-buster-browsers@* python3.7/python3.7-minimal@3.7.3-2+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream python3.7 package.

The package python/cpython from 0 and before 3.6.13, from 3.7.0 and before 3.7.10, from 3.8.0 and before 3.8.8, from 3.9.0 and before 3.9.2 are vulnerable to Web Cache Poisoning via urllib.parse.parse_qsl and urllib.parse.parse_qs by using a vector called parameter cloaking. When the attacker can separate query parameters using a semicolon (;), they can cause a difference in the interpretation of the request between the proxy (running with default configuration) and the server. This can result in malicious requests being cached as completely safe ones, as the proxy would usually not see the semicolon as a separator, and therefore would not include it in a cache key of an unkeyed parameter.

Remediation

There is no fixed version for Debian:10 python3.7.

References

medium severity

Information Exposure

  • Vulnerable module: python3.7
  • Introduced through: python3.7@3.7.3-2+deb10u3, python3.7/libpython3.7-minimal@3.7.3-2+deb10u3 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* python3.7@3.7.3-2+deb10u3
  • Introduced through: circleci/node:dubnium-buster-browsers@* python3.7/libpython3.7-minimal@3.7.3-2+deb10u3
  • Introduced through: circleci/node:dubnium-buster-browsers@* python3.7/libpython3.7-stdlib@3.7.3-2+deb10u3
  • Introduced through: circleci/node:dubnium-buster-browsers@* python3.7/python3.7-minimal@3.7.3-2+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream python3.7 package.

There's a flaw in Python 3's pydoc. A local or adjacent attacker who discovers or is able to convince another local or adjacent user to start a pydoc server could access the server and use it to disclose sensitive information belonging to the other user that they would not normally be able to access. The highest risk of this flaw is to data confidentiality. This flaw affects Python versions before 3.8.9, Python versions before 3.9.3 and Python versions before 3.10.0a7.

Remediation

There is no fixed version for Debian:10 python3.7.

References

medium severity

CVE-2020-13631

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.27.2-3+deb10u1 and sqlite3/libsqlite3-dev@3.27.2-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* sqlite3/libsqlite3-0@3.27.2-3+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* sqlite3/libsqlite3-dev@3.27.2-3+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package.

SQLite before 3.32.0 allows a virtual table to be renamed to the name of one of its shadow tables, related to alter.c and build.c.

Remediation

There is no fixed version for Debian:10 sqlite3.

References

medium severity

Improper Handling of Exceptional Conditions

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.27.2-3+deb10u1 and sqlite3/libsqlite3-dev@3.27.2-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* sqlite3/libsqlite3-0@3.27.2-3+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* sqlite3/libsqlite3-dev@3.27.2-3+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package.

SQLite 3.30.1 mishandles certain parser-tree rewriting, related to expr.c, vdbeaux.c, and window.c. This is caused by incorrect sqlite3WindowRewrite() error handling.

Remediation

There is no fixed version for Debian:10 sqlite3.

References

medium severity

Uncontrolled Recursion

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.27.2-3+deb10u1 and sqlite3/libsqlite3-dev@3.27.2-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* sqlite3/libsqlite3-0@3.27.2-3+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* sqlite3/libsqlite3-dev@3.27.2-3+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package.

alter.c in SQLite through 3.30.1 allows attackers to trigger infinite recursion via certain types of self-referential views in conjunction with ALTER TABLE statements.

Remediation

There is no fixed version for Debian:10 sqlite3.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: sysstat
  • Introduced through: sysstat@12.0.3-2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* sysstat@12.0.3-2

NVD Description

Note: Versions mentioned in the description apply to the upstream sysstat package.

sysstat before 12.1.6 has memory corruption due to an Integer Overflow in remap_struct() in sa_common.c.

Remediation

There is no fixed version for Debian:10 sysstat.

References

medium severity

Link Following

  • Vulnerable module: unbound/libunbound8
  • Introduced through: unbound/libunbound8@1.9.0-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* unbound/libunbound8@1.9.0-2+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream unbound package.

NLnet Labs Unbound, up to and including version 1.12.0, and NLnet Labs NSD, up to and including version 4.3.3, contain a local vulnerability that would allow for a local symlink attack. When writing the PID file, Unbound and NSD create the file if it is not there, or open an existing file for writing. In case the file was already present, they would follow symlinks if the file happened to be a symlink instead of a regular file. An additional chown of the file would then take place after it was written, making the user Unbound/NSD is supposed to run as the new owner of the file. If an attacker has local access to the user Unbound/NSD runs as, she could create a symlink in place of the PID file pointing to a file that she would like to erase. If then Unbound/NSD is killed and the PID file is not cleared, upon restarting with root privileges, Unbound/NSD will rewrite any file pointed at by the symlink. This is a local vulnerability that could create a Denial of Service of the system Unbound/NSD is running on. It requires an attacker having access to the limited permission user Unbound/NSD runs as and point through the symlink to a critical file on the system.

Remediation

There is no fixed version for Debian:10 unbound.

References

medium severity

Open Redirect

  • Vulnerable module: wget
  • Introduced through: wget@1.20.1-1.1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* wget@1.20.1-1.1

NVD Description

Note: Versions mentioned in the description apply to the upstream wget package.

GNU Wget through 1.21.1 does not omit the Authorization header upon a redirect to a different origin, a related issue to CVE-2018-1000007.

Remediation

There is no fixed version for Debian:10 wget.

References

medium severity

Information Exposure

  • Vulnerable module: xdg-utils
  • Introduced through: xdg-utils@1.1.3-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* xdg-utils@1.1.3-1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream xdg-utils package.

A flaw was found in the xdg-email component of xdg-utils-1.1.0-rc1 and newer. When handling mailto: URIs, xdg-email allows attachments to be discreetly added via the URI when being passed to Thunderbird. An attacker could potentially send a victim a URI that automatically attaches a sensitive file to a new email. If a victim user does not notice that an attachment was added and sends the email, this could result in sensitive information disclosure. It has been confirmed that the code behind this issue is in xdg-email and not in Thunderbird.

Remediation

There is no fixed version for Debian:10 xdg-utils.

References

low severity

Security Features

  • Vulnerable module: apparmor/libapparmor1
  • Introduced through: apparmor/libapparmor1@2.13.2-10

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* apparmor/libapparmor1@2.13.2-10

NVD Description

Note: Versions mentioned in the description apply to the upstream apparmor package.

In all versions of AppArmor mount rules are accidentally widened when compiled.

Remediation

There is no fixed version for Debian:10 apparmor.

References

low severity

Improper Verification of Cryptographic Signature

  • Vulnerable module: apt
  • Introduced through: apt@1.8.2.2 and apt/libapt-pkg5.0@1.8.2.2

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* apt@1.8.2.2
  • Introduced through: circleci/node:dubnium-buster-browsers@* apt/libapt-pkg5.0@1.8.2.2

NVD Description

Note: Versions mentioned in the description apply to the upstream apt package.

It was found that apt-key in apt, all versions, do not correctly validate gpg keys with the master keyring, leading to a potential man-in-the-middle attack.

Remediation

There is no fixed version for Debian:10 apt.

References

low severity

Origin Validation Error

  • Vulnerable module: avahi/libavahi-client3
  • Introduced through: avahi/libavahi-client3@0.7-4+deb10u1, avahi/libavahi-common-data@0.7-4+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* avahi/libavahi-client3@0.7-4+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* avahi/libavahi-common-data@0.7-4+deb10u1
  • Introduced through: circleci/node:dubnium-buster-browsers@* avahi/libavahi-common3@0.7-4+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream avahi package.

avahi-daemon in Avahi through 0.6.32 and 0.7 inadvertently responds to IPv6 unicast queries with source addresses that are not on-link, which allows remote attackers to cause a denial of service (traffic amplification) and may cause information leakage by obtaining potentially sensitive information from the responding device via port-5353 UDP packets. NOTE: this may overlap CVE-2015-2809.

Remediation

There is no fixed version for Debian:10 avahi.

References

low severity

Improper Check for Dropped Privileges

  • Vulnerable module: bash
  • Introduced through: bash@5.0-4

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* bash@5.0-4

NVD Description

Note: Versions mentioned in the description apply to the upstream bash package.

An issue was discovered in disable_priv_mode in shell.c in GNU Bash through 5.0 patch 11. By default, if Bash is run with its effective UID not equal to its real UID, it will drop privileges by setting its effective UID to its real UID. However, it does so incorrectly. On Linux and other systems that support "saved UID" functionality, the saved UID is not dropped. An attacker with command execution in the shell can use "enable -f" for runtime loading of a new builtin, which can be a shared object that calls setuid() and therefore regains privileges. However, binaries running with an effective UID of 0 are unaffected.

Remediation

There is no fixed version for Debian:10 bash.

References

low severity

Allocation of Resources Without Limits or Throttling

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.32. It is an attempted excessive memory allocation in _bfd_elf_slurp_version_tables in elf.c.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Allocation of Resources Without Limits or Throttling

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

The C++ symbol demangler routine in cplus-dem.c in libiberty, as distributed in GNU Binutils 2.29, allows remote attackers to cause a denial of service (excessive memory allocation and application crash) via a crafted file, as demonstrated by a call from the Binary File Descriptor (BFD) library (aka libbfd).

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Allocation of Resources Without Limits or Throttling

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

remember_Ktype in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.30, allows attackers to trigger excessive memory consumption (aka OOM). This can occur during execution of cxxfilt.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Double Free

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A double free vulnerability exists in the Binary File Descriptor (BFD) (aka libbrd) in GNU Binutils 2.35 in the process_symbol_table, as demonstrated in readelf, via a crafted file.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Improper Input Validation

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A flaw exists in binutils in bfd/pef.c. An attacker who is able to submit a crafted PEF file to be parsed by objdump could cause a heap buffer overflow -> out-of-bounds read that could lead to an impact to application availability. This flaw affects binutils versions prior to 2.34.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Improper Input Validation

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

There's a flaw in the BFD library of binutils in versions before 2.36. An attacker who supplies a crafted file to an application linked with BFD, and using the DWARF functionality, could cause an impact to system availability by way of excessive memory consumption.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Improper Input Validation

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

GNU binutils gold gold v1.11-v1.16 (GNU binutils v2.21-v2.31.1) is affected by: Improper Input Validation, Signed/Unsigned Comparison, Out-of-bounds Read. The impact is: Denial of service. The component is: gold/fileread.cc:497, elfcpp/elfcpp_file.h:644. The attack vector is: An ELF file with an invalid e_shoff header field must be opened.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Integer Overflow or Wraparound

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils through 2.31. There is an integer overflow and infinite loop caused by the IS_CONTAINED_BY_LMA macro in elf.c.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Integer Overflow or Wraparound

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

The get_count function in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.31, allows remote attackers to cause a denial of service (malloc called with the result of an integer-overflowing calculation) or possibly have unspecified other impact via a crafted string, as demonstrated by c++filt.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Integer Overflow or Wraparound

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

apply_relocations in readelf.c in GNU Binutils 2.32 contains an integer overflow that allows attackers to trigger a write access violation (in byte_put_little_endian function in elfcomm.c) via an ELF file, as demonstrated by readelf.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Integer Overflow or Wraparound

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.32. It is an integer overflow leading to a SEGV in _bfd_dwarf2_find_nearest_line in dwarf2.c, as demonstrated by nm.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Link Following

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

There is an open race window when writing output in the following utilities in GNU binutils version 2.35 and earlier:ar, objcopy, strip, ranlib. When these utilities are run as a privileged user (presumably as part of a script updating binaries across different users), an unprivileged user can trick these utilities into getting ownership of arbitrary files through a symlink.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A Stack Exhaustion issue was discovered in debug_write_type in debug.c in GNU Binutils 2.30 because of DEBUG_KIND_INDIRECT infinite recursion.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in cp-demangle.c in GNU libiberty, as distributed in GNU Binutils 2.31. There is a stack consumption vulnerability resulting from infinite recursion in the functions d_name(), d_encoding(), and d_local_name() in cp-demangle.c. Remote attackers could leverage this vulnerability to cause a denial-of-service via an ELF file, as demonstrated by nm.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in cp-demangle.c in GNU libiberty, as distributed in GNU Binutils 2.31. There is a stack consumption vulnerability resulting from infinite recursion in the functions next_is_type_qual() and cplus_demangle_type() in cp-demangle.c. Remote attackers could leverage this vulnerability to cause a denial-of-service via an ELF file, as demonstrated by nm.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Missing Release of Resource after Effective Lifetime

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

The _bfd_generic_read_minisymbols function in syms.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31, has a memory leak via a crafted ELF file, leading to a denial of service (memory consumption), as demonstrated by nm.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A Null Pointer Dereference vulnerability exists in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.35, in scan_unit_for_symbols, as demonstrated in addr2line, that can cause a denial of service via a crafted file.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A Null Pointer Dereference vulnerability exists in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.35, in _bfd_elf_get_symbol_version_string, as demonstrated in nm-new, that can cause a denial of service via a crafted file.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

There's a flaw in binutils /bfd/pef.c. An attacker who is able to submit a crafted input file to be processed by the objdump program could cause a null pointer dereference. The greatest threat from this flaw is to application availability. This flaw affects binutils versions prior to 2.34.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

There's a flaw in bfd_pef_scan_start_address() of bfd/pef.c in binutils which could allow an attacker who is able to submit a crafted file to be processed by objdump to cause a NULL pointer dereference. The greatest threat of this flaw is to application availability. This flaw affects binutils versions prior to 2.34.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

There's a flaw in bfd_pef_parse_function_stubs of bfd/pef.c in binutils in versions prior to 2.34 which could allow an attacker who is able to submit a crafted file to be processed by objdump to cause a NULL pointer dereference. The greatest threat of this flaw is to application availability.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the merge_strings function in merge.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31. There is a NULL pointer dereference in _bfd_add_merge_section when attempting to merge sections with large alignments. A specially crafted ELF allows remote attackers to cause a denial of service, as demonstrated by ld.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A NULL pointer dereference was discovered in elf_link_add_object_symbols in elflink.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31.1. This occurs for a crafted ET_DYN with no program headers. A specially crafted ELF file allows remote attackers to cause a denial of service, as demonstrated by ld.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in elf_link_input_bfd in elflink.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31. There is a NULL pointer dereference in elf_link_input_bfd when used for finding STT_TLS symbols without any TLS section. A specially crafted ELF allows remote attackers to cause a denial of service, as demonstrated by ld.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.31. There is a NULL pointer dereference in work_stuff_copy_to_from when called from iterate_demangle_function.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A NULL pointer dereference (aka SEGV on unknown address 0x000000000000) was discovered in work_stuff_copy_to_from in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.30. This can occur during execution of objdump.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-Bounds

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A flaw was found in GNU Binutils 2.35.1, where there is a heap-based buffer overflow in _bfd_elf_slurp_secondary_reloc_section in elf.c due to the number of symbols not calculated correctly. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-Bounds

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A flaw was found in binutils readelf 2.35 program. An attacker who is able to convince a victim using readelf to read a crafted file could trigger a stack buffer overflow, out-of-bounds write of arbitrary data supplied by the attacker. The highest impact of this flaw is to confidentiality, integrity, and availability.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-Bounds

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An out of bounds flaw was found in GNU binutils objdump utility version 2.36. An attacker could use this flaw and pass a large section to avr_elf32_load_records_from_section() probably resulting in a crash or in some cases memory corruption. The highest threat from this vulnerability is to integrity as well as system availability.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-Bounds

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31. An invalid memory access exists in _bfd_stab_section_find_nearest_line in syms.c. Attackers could leverage this vulnerability to cause a denial of service (application crash) via a crafted ELF file.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-Bounds

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31. An invalid memory access exists in bfd_zalloc in opncls.c. Attackers could leverage this vulnerability to cause a denial of service (application crash) via a crafted ELF file.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-Bounds

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31. An invalid memory address dereference was discovered in read_reloc in reloc.c. The vulnerability causes a segmentation fault and application crash, which leads to denial of service, as demonstrated by objdump, because of missing _bfd_clear_contents bounds checking.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-Bounds

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

GNU gdb All versions is affected by: Buffer Overflow - Out of bound memory access. The impact is: Deny of Service, Memory Disclosure, and Possible Code Execution. The component is: The main gdb module. The attack vector is: Open an ELF for debugging. The fixed version is: Not fixed yet.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A Denial of Service vulnerability exists in the Binary File Descriptor (BFD) in GNU Binutils 2.35 due to an invalid read in process_symbol_table, as demonstrated in readeif.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in GNU libiberty, as distributed in GNU Binutils 2.32. It is a heap-based buffer over-read in d_expression_1 in cp-demangle.c after many recursive calls.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.32. It is an out-of-bounds read leading to a SEGV in bfd_getl32 in libbfd.c, when called from pex64_get_runtime_function in pei-x86_64.c.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31. a heap-based buffer over-read in bfd_getl32 in libbfd.c allows an attacker to cause a denial of service through a crafted PE file. This vulnerability can be triggered by the executable objdump.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A heap-based buffer over-read issue was discovered in the function sec_merge_hash_lookup in merge.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.31, because _bfd_add_merge_section mishandles section merges when size is not a multiple of entsize. A specially crafted ELF allows remote attackers to cause a denial of service, as demonstrated by ld.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A heap-based buffer over-read exists in the function d_expression_1 in cp-demangle.c in GNU libiberty, as distributed in GNU Binutils 2.31.1. A crafted input can cause segmentation faults, leading to denial-of-service, as demonstrated by c++filt.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.32. There is a heap-based buffer over-read in _bfd_doprnt in bfd.c because elf_object_p in elfcode.h mishandles an e_shstrndx section of type SHT_GROUP by omitting a trailing '\0' character.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.35.1. A heap-based buffer over-read can occur in bfd_getl_signed_32 in libbfd.c because sh_entsize is not validated in _bfd_elf_slurp_secondary_reloc_section in elf.c.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.32. It is a heap-based buffer overflow in _bfd_archive_64_bit_slurp_armap in archive64.c.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in GNU Binutils 2.32. It is a heap-based buffer overflow in process_mips_specific in readelf.c via a malformed MIPS option section.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

The demangle_template function in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.31.1, contains an integer overflow vulnerability (for "Create an array for saving the template argument values") that can trigger a heap-based buffer overflow, as demonstrated by nm.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

binutils version 2.32 and earlier contains a Integer Overflow vulnerability in objdump, bfd_get_dynamic_reloc_upper_bound,bfd_canonicalize_dynamic_reloc that can result in Integer overflow trigger heap overflow. Successful exploitation allows execution of arbitrary code.. This attack appear to be exploitable via Local. This vulnerability appears to have been fixed in after commit 3a551c7a1b80fca579461774860574eabfd7f18f.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils through 2.31. There is a heap-based buffer overflow in bfd_elf32_swap_phdr_in in elfcode.h because the number of program headers is not restricted.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

load_specific_debug_section in objdump.c in GNU Binutils through 2.31.1 contains an integer overflow vulnerability that can trigger a heap-based buffer overflow via a crafted section size.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

finish_stab in stabs.c in GNU Binutils 2.30 allows attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact, as demonstrated by an out-of-bounds write of 8 bytes. This can occur during execution of objdump.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in GNU libiberty, as distributed in GNU Binutils 2.32. simple_object_elf_match in simple-object-elf.c does not check for a zero shstrndx value, leading to an integer overflow and resultant heap-based buffer overflow.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Resource Exhaustion

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in cp-demangle.c in GNU libiberty, as distributed in GNU Binutils 2.31. There is a stack consumption problem caused by the cplus_demangle_type function making recursive calls to itself in certain scenarios involving many 'P' characters.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Resource Management Errors

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

demangle_template in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.30, allows attackers to trigger excessive memory consumption (aka OOM) during the "Create an array for saving the template argument values" XNEWVEC call. This can occur during execution of objdump.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A flaw was discovered in GNU libiberty within demangle_path() in rust-demangle.c, as distributed in GNU Binutils version 2.36. A crafted symbol can cause stack memory to be exhausted leading to a crash.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in GNU libiberty, as distributed in GNU Binutils 2.32. It is a stack consumption issue in d_count_templates_scopes in cp-demangle.c after many recursive calls.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in cp-demangle.c in GNU libiberty, as distributed in GNU Binutils 2.31. Stack Exhaustion occurs in the C++ demangling functions provided by libiberty, and there is a stack consumption problem caused by recursive stack frames: cplus_demangle_type, d_bare_function_type, d_function_type.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.29 and 2.30. Stack Exhaustion occurs in the C++ demangling functions provided by libiberty, and there are recursive stack frames: demangle_nested_args, demangle_args, do_arg, and do_type.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.30. Stack Exhaustion occurs in the C++ demangling functions provided by libiberty, and there are recursive stack frames: demangle_template_value_parm, demangle_integral_value, and demangle_expression.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

find_abstract_instance in dwarf2.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.32, allows remote attackers to cause a denial of service (infinite recursion and application crash) via a crafted ELF file.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Use After Free

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A use after free issue exists in the Binary File Descriptor (BFD) library (aka libbfd) in GNU Binutils 2.34 in bfd_hash_lookup, as demonstrated in nm-new, that can cause a denial of service via a crafted file.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Use After Free

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

In GNU Binutils 2.31.1, there is a use-after-free in the error function in elfcomm.c when called from the process_archive function in readelf.c via a crafted ELF file.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity

Use of Uninitialized Resource

  • Vulnerable module: binutils
  • Introduced through: binutils@2.31.1-16, binutils/binutils-common@2.31.1-16 and others

Detailed paths

  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-common@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/binutils-x86-64-linux-gnu@2.31.1-16
  • Introduced through: circleci/node:dubnium-buster-browsers@* binutils/libbinutils@2.31.1-16

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

There's a flaw in binutils /opcodes/tic4x-dis.c. An attacker who is able to submit a crafted input file to be processed by binutils could cause usage of uninitialized memory. The highest threat is to application availability with a lower threat to data confidentiality. This flaw affects binutils versions prior to 2.34.

Remediation

There is no fixed version for Debian:10 binutils.

References

low severity