Information Exposure

Affecting libgcrypt20 package, versions <1.8.4-5+deb10u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream libgcrypt20 package. See Remediation section below for Debian:10 relevant versions.

Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. This, for example, affects use of ElGamal in OpenPGP.

Remediation

Upgrade Debian:10 libgcrypt20 to version 1.8.4-5+deb10u1 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVE
CVE-2021-33560
CWE
CWE-203
Snyk ID
SNYK-DEBIAN10-LIBGCRYPT20-1297893
Disclosed
08 Jun, 2021
Published
29 May, 2021