Use After Free

Affecting gnutls28 package, versions <3.6.7-4+deb10u7

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in gnutls. A use after free issue in client sending key_share extension may lead to memory corruption and other consequences.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u7 or higher.

References

CVSS Score

9.8
critical severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2021-20231
CWE
CWE-416
Snyk ID
SNYK-DEBIAN10-GNUTLS28-1085094
Disclosed
12 Mar, 2021
Published
11 Mar, 2021