next-update

Tests if module's dependencies can be updated to the newer version without breaking the tests.

Known vulnerabilities2
Vulnerable paths4
Dependencies279

Uninitialized Memory Exposure

medium severity
  • Vulnerable module: tunnel-agent
  • Introduced through: request@2.74.0

Detailed paths

  • Introduced through: next-update@bahmutov/next-update#230d136b5c68dadb1fd5459619df8f7678d28429 request@2.74.0 tunnel-agent@0.4.3

Overview

tunnel-agent is HTTP proxy tunneling agent. Affected versions of the package are vulnerable to Uninitialized Memory Exposure.

A possible memory disclosure vulnerability exists when a value of type number is used to set the proxy.auth option of a request request and results in a possible uninitialized memory exposures in the request body.

This is a result of unobstructed use of the Buffer constructor, whose insecure default constructor increases the odds of memory leakage.

Details

Constructing a Buffer class with integer N creates a Buffer of length N with raw (not "zero-ed") memory.

In the following example, the first call would allocate 100 bytes of memory, while the second example will allocate the memory needed for the string "100":

// uninitialized Buffer of length 100
            x = new Buffer(100);
            // initialized Buffer with value of '100'
            x = new Buffer('100');
            

tunnel-agent's request construction uses the default Buffer constructor as-is, making it easy to append uninitialized memory to an existing list. If the value of the buffer list is exposed to users, it may expose raw server side memory, potentially holding secrets, private data and code. This is a similar vulnerability to the infamous Heartbleed flaw in OpenSSL.

Proof of concept by ChALkeR

require('request')({
              method: 'GET',
              uri: 'http://www.example.com',
              tunnel: true,
              proxy:{
                  protocol: 'http:',
                  host:"127.0.0.1",
                  port:8080,
                  auth:80
              }
            });
            

You can read more about the insecure Buffer behavior on our blog.

Similar vulnerabilities were discovered in request, mongoose, ws and sequelize.

Remediation

Upgrade tunnel-agent to version 0.6.0 or higher.

References

Regular Expression Denial of Service (ReDoS)

low severity
  • Vulnerable module: ms
  • Introduced through: debug@2.2.0, changed-log@0.11.0 and others

Detailed paths

  • Introduced through: next-update@bahmutov/next-update#230d136b5c68dadb1fd5459619df8f7678d28429 debug@2.2.0 ms@0.7.1
  • Introduced through: next-update@bahmutov/next-update#230d136b5c68dadb1fd5459619df8f7678d28429 changed-log@0.11.0 debug@2.2.0 ms@0.7.1
  • Introduced through: next-update@bahmutov/next-update#230d136b5c68dadb1fd5459619df8f7678d28429 npm-utils@1.7.1 debug@2.2.0 ms@0.7.1

Overview

ms is a tiny milisecond conversion utility. Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) due to an incomplete fix for previously reported vulnerability npm:ms:20151024. The fix limited the length of accepted input string to 10,000 characters, and turned to be insufficient making it possible to block the event loop for 0.3 seconds (on a typical laptop) with a specially crafted string passed to ms() function.

Proof of concept

ms = require('ms');
            ms('1'.repeat(9998) + 'Q') // Takes about ~0.3s
            

Note: Snyk's patch for this vulnerability limits input length to 100 characters. This new limit was deemed to be a breaking change by the author. Based on user feedback, we believe the risk of breakage is very low, while the value to your security is much greater, and therefore opted to still capture this change in a patch for earlier versions as well. Whenever patching security issues, we always suggest to run tests on your code to validate that nothing has been broken.

For more information on Regular Expression Denial of Service (ReDoS) attacks, go to our blog.

Disclosure Timeline

  • Feb 9th, 2017 - Reported the issue to package owner.
  • Feb 11th, 2017 - Issue acknowledged by package owner.
  • April 12th, 2017 - Fix PR opened by Snyk Security Team.
  • May 15th, 2017 - Vulnerability published.
  • May 16th, 2017 - Issue fixed and version 2.0.0 released.
  • May 21th, 2017 - Patches released for versions >=0.7.1, <=1.0.0.

Remediation

Upgrade ms to version 2.0.0 or higher.

References