Prototype Pollution

Affecting lodash package, versions <4.17.11

Overview

lodash is a modern JavaScript utility library delivering modularity, performance, & extras.

Affected versions of this package are vulnerable to Prototype Pollution. The functions merge, mergeWith, and defaultsDeep could be tricked into adding or modifying properties of Object.prototype.

Remediation

Upgrade lodash to version 4.17.11 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

1.8
low severity
  • Attack Vector
    Local
  • Attack Complexity
    High
  • Privileges Required
    High
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    Low
CVSS:3.0/AV:L/AC:H/PR:H/UI:R/S:U/C:N/I:N/A:L/E:F/RL:O/RC:C
Credit
asgerf
CVE
CVE-2018-16487
CWE
CWE-400
Snyk ID
SNYK-JS-LODASH-73638
Disclosed
31 Aug, 2018
Published
01 Feb, 2019