Vulnerability DB

Detailed information and remediation guidance for known vulnerabilities.
Find out if you have vulnerabilities that put you at risk Test your code
Vulnerability Affects Type Published
  • H
Cross-site Scripting (XSS)
marked >=0.3.1 <0.3.6 npm 20 Apr, 2016
  • H
Regular Expression Denial of Service (ReDoS)
marked <0.3.18 npm 27 Feb, 2018
  • H
Cross-site Scripting (XSS)
marked <0.3.9 npm 25 Dec, 2017
  • H
Regular Expression Denial of Service (ReDoS)
marked <0.3.9 npm 21 Sep, 2017
  • H
Cross-site Scripting (XSS)
marked <0.3.7 npm 30 Jan, 2017
  • H
Regular Expression Denial of Service (ReDoS)
marked <0.3.4 npm 30 Jan, 2014
  • M
VBScript Content Injection
marked <0.3.3 npm 30 Jan, 2014
  • M
Multiple Content Injection Vulnerabilities
marked <=0.3.0 npm 30 Jan, 2014
  • M
Regular Expression Denial of Service (ReDoS)
marked <0.4.0 npm 04 Jul, 2019
  • M
Regular Expression Denial of Service (ReDoS)
marked >=0.4.0 <0.7.0 npm 02 Jul, 2019
  • M
Regular Expression Denial of Service (ReDoS)
marked >=0.1.3 <0.6.2 npm 07 Apr, 2019
  • M
Cross-site Scripting (XSS)
marked <0.3.9 npm 25 Dec, 2017
  • M
Regular Expression Denial of Service (ReDoS)
marked >=0.5.0 <0.6.1 npm 30 Jan, 2019
  • H
Cross-site Scripting (XSS)
react-marked-markdown * npm 22 May, 2018