Regular Expression Denial of Service (ReDoS)

Affecting marked package, versions >=0.5.0 <0.6.1

Do your applications use this vulnerable package? Test your applications

Overview

marked is a low-level compiler for parsing markdown without caching or blocking for long periods of time.

Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS). Input to the host variable is vulnerable when input contains parenthesis in link URIs, coupled with a high number of link tokens in a single line.

Remediation

Upgrade marked to version 0.6.1 or higher.

References

CVSS Score

4.4
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
Credit
Vanessa219
CWE
CWE-400
Snyk ID
SNYK-JS-MARKED-73637
Disclosed
30 Jan, 2019
Published
30 Jan, 2019