Open Redirect

Affecting url-parse package, versions <1.4.3

high severity

Overview

url-parse is a Small footprint URL parser that works seamlessly across Node.js and browser environments.

Affected versions of this package are vulnerable to Open Redirect, Server Side Request Forgery (SSRF) and Bypass Authentication Protocol due to returning wrong hostname.

Remediation

Upgrade url-parse to version 1.4.3 or higher.

References

Do your applications use this vulnerable package?

Credit
Ahmed
CVE
CVE-2018-3774
CWE
CWE-601
Snyk ID
npm:url-parse:20180731
Disclosed
31 Jul, 2018
Published
31 Jul, 2018