Potential Script Injection

Affecting syntax-error package, versions < 1.1.1

Do your applications use this vulnerable package? Test your applications

Overview

There was a security vulnerability where a malicious file could execute code when browserified. Make sure your installation of browserify is using syntax-error@1.1.1 or later.

Source: Node Security Project

Details

The vulnerability involves breaking out of Function(), which was used to check syntax for more informative errors. In node 0.10, Function() seems to be implemented in terms of eval(), so malicious code can execute even if the function returned by Function() was never called. node 0.11 does not appear to be vulnerable.

Thanks to [Cal Leeming] (cal@iops.io) for discovering and disclosing this bug!

Remediation

Update to version 1.1.1 or greater. If this is being used in conjunction with browserify, update browserify to 4.2.1 or greater.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Credit
Cal Leeming
CVE
CVE-2014-7192
CWE
CWE-94
Snyk ID
npm:syntax-error:20140715
Disclosed
15 Jul, 2014
Published
15 Jul, 2014