SQL Injection

Affecting sequelize package, versions <3.20.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

sequelize versions prior to 3.20.0 improperly escape arrays of strings bound to named parameters.

Remediation

Upgrade to version 3.20.0 or greater.

References

Snyk patch available for versions:

CVSS Score

4.8
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Unknown
CVE
CVE-2016-10556
CWE
CWE-89
Snyk ID
npm:sequelize:20160329
Disclosed
29 Mar, 2016
Published
01 Apr, 2016