Arbitrary Code Injection

Affecting pouchdb package, versions <6.0.5

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Remediation

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
micaksica
CVE
CVE-2016-10546
CWE
CWE-94
Snyk ID
npm:pouchdb:20160830
Disclosed
30 Aug, 2016
Published
17 Oct, 2016