Directory Traversal

Affecting list-n-stream package, versions <0.0.11

high severity

Overview

list-n-stream is super basic dirlist and file streaming server. Affected versions of the package are vulnerable to Directory Traversal, which may allow access to sensitive files and data on the server. For example, requesting the following url /..%2f..%2fetc/passwd would result in /etc/passwd leak.

Thanks to Liang Gong for disclosing this vulnerability!

Disclosure Timeline

  • April 24th, 2017 - Disclosed to package owner
  • April 24th, 2017 - Issue acknowledged by package owner.
  • April 24th, 2017 - Issue fixed and version 0.0.11 released.

Remediation

Upgrade list-n-stream to version 0.0.11 or higher.

References

Credit
Liang Gong
CWE
CWE-22
Snyk ID
npm:list-n-stream:20170418
Disclosed
17 Apr, 2017
Published
24 Apr, 2017

Do your applications use this vulnerable package?