LDAP Injection

Affecting ldapauth-fork package, versions < 2.3.3

Do your applications use this vulnerable package? Test your applications

Overview

ldapauth-fork versions < 2.3.3 are vulnerable to ldap injection through the username parameter.

Source: Node Security Project

Remediation

Upgrade to ldapauth-fork 2.3.3 or greater.

References:

Snyk patch available for versions:

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Jerome Touffe-Blin
CVE
CVE-2015-7294
CWE
CWE-90
Snyk ID
npm:ldapauth-fork:20150918
Disclosed
18 Sep, 2015
Published
18 Sep, 2015