Out of Memory Crash

Affecting js-quantities package, versions <1.7.0

Do your applications use this vulnerable package? Test your applications

Overview

js-quantities is JavaScript library for quantity calculation and unit conversion. Affected versions of the package are vulnerable to Out of Memory Crash.

Remediation

Upgrade js-quantities to version 1.7.0 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Credit
Zach Bjornson
CWE
CWE-119
Snyk ID
npm:js-quantities:20161111
Disclosed
10 Nov, 2016
Published
02 Aug, 2017