high severity
npm

Arbitrary JavaScript Code Injection

Affected package Vulnerable versions Latest version Snyk patch
bassmaster <=1.5.1 2.0.3 Available

Overview

Old versions of bassmaster, a Hapi server plugin used to process batches of requests, use the eval method as part of its processing and validation of user input.

An attacker can therefore provide arbitrary javascript in this input, which will be executed by this eval function without limitation.

This is a very severe remote JavaScript code execution, and depending on the node process permissions can turn into Arbitrary Remote Code Execution on the operating system level as well.

Remediation

Update to bassmaster version 1.5.2 or greater.

References

Snyk patch

Available for versions: