Cross-site Request Forgery (CSRF)

Affecting auth0-lock package, versions <11.0.0

Do your applications use this vulnerable package? Test your applications

Overview

auth0-lock is an authentication broker that supports both social and enterprise identity providers, including Active Directory, LDAP, Google Apps, and Salesforce.

Affected versions of this package are vulnerable to Cross-Site Request Forgery (CSRF) attacks if the Legacy Lock API flag is enabled.

Once the user credentials are verified, an HTML form is rendered into the user’s browser. A JSON Web Token (JWT) is POSTed to the /login/callback endpoint, and it maintains state regarding the identity of the user. Due to the lack of session binding, this form post is susceptible to CSRF. An attacker with valid user credentials at an Auth0 tenant can use them to gain such a form, and then employ techniques such as social engineering or clickjacking to have a victim’s browser execute it.

Remediation

Upgrade auth0-lock to version 11.0.0 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Unknown
CVE
CVE-2018-6874
CWE
CWE-352
Snyk ID
npm:auth0-lock:20180409
Disclosed
09 Apr, 2018
Published
09 Apr, 2018