Cross-site Scripting (XSS)

Affecting angular package, versions >=1.0.0 <1.5.0-beta.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

angular is a package that lets you write client-side web applications as if you had a smarter browser. It also lets you use HTML as your template language and lets you extend HTML’s syntax to express your application’s components clearly and succinctly.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) due to no proper sanitization of xlink:href attributes.

Remediation

Upgrade angular to version 1.5.0-beta.0 or higher.

References

CVSS Score

7.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
Credit
Igor Minar
CVE
CVE-2019-14863
CWE
CWE-78
Snyk ID
npm:angular:20150807
Disclosed
06 Aug, 2015
Published
23 Jan, 2017