HTTP Request Smuggling

Affecting puma gem, versions <3.12.5 || >=4.0.0, <4.3.4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack applications. Puma is intended for use in both development and production environments. It's great for highly concurrent Ruby implementations such as Rubinius and JRuby as well as as providing process worker support to support CRuby well.

Affected versions of this package are vulnerable to HTTP Request Smuggling. An attacker could smuggle an HTTP response, by using an invalid transfer-encoding header.

Remediation

Upgrade puma to version 3.12.5, 4.3.4 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:R
Credit
Zeddy Yu
CVE
CVE-2020-11076
CWE
CWE-444
Snyk ID
SNYK-RUBY-PUMA-570205
Disclosed
22 May, 2020
Published
22 May, 2020