Remote Code Execution

Affecting mini_magick gem, versions <4.9.4

Do your applications use this vulnerable package? Test your applications

Overview

mini_magick is a ruby wrapper for ImageMagick or GraphicsMagick command line.

Affected versions of this package are vulnerable to Remote Code Execution. A fetched remote image filename can cause remote command execution due to Image.open input being directly passed to Kernel#open, which accepts a | character followed by a command.

Remediation

Upgrade mini_magick to version 4.9.4 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Credit
Janko Marohnic
CVE
CVE-2019-13574
CWE
CWE-94
Snyk ID
SNYK-RUBY-MINIMAGICK-451567
Disclosed
12 Jul, 2019
Published
12 Jul, 2019