Remote Code Execution

Affecting kramdown gem, versions <2.3.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

kramdown is a Yet-another-markdown-parser but fast, pure Ruby, using a strict syntax definition and supporting several common extensions.

Affected versions of this package are vulnerable to Remote Code Execution. The gem processes the template option inside Kramdown documents by default, which allows unintended read access (such as template="/etc/passwd") or unintended embedded Ruby code execution (such as a string that begins with template="string://<%= `).

Remediation

Upgrade kramdown to version 2.3.0 or higher.

References

CVSS Score

7.2
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2020-14001
CWE
CWE-22
Snyk ID
SNYK-RUBY-KRAMDOWN-585939
Disclosed
19 Jul, 2020
Published
19 Jul, 2020