Denial of Service (DoS)

Affecting json gem, versions <2.3.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

json is a JSON implementation as a Ruby extension in C

Affected versions of this package are vulnerable to Denial of Service (DoS). When parsing certain JSON documents, the json gem (including the one bundled with Ruby) can be coerced into creating arbitrary objects in the target system.

This is the same issue as CVE-2013-0269. The previous fix was incomplete, which addressed JSON.parse(user_input), but didn’t address some other styles of JSON parsing including JSON(user_input) and JSON.parse(user_input, nil).

See CVE-2013-0269 in detail.

Remediation

Upgrade json to version 2.3.0 or higher.

References

CVSS Score

9.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Changed
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:H
Credit
Unknown
CVE
CVE-2020-10663
CWE
CWE-400
Snyk ID
SNYK-RUBY-JSON-560838
Disclosed
20 Mar, 2020
Published
19 Mar, 2020