Remote Code Execution (RCE)

Affecting actionview gem, versions <4.2.11.3 || >=5.0.0, <5.0.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

actionview is a simple, battle-tested conventions and helpers for building web pages.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). An attacker might be able to control the locals argument of a render call.

Note: It doesn't affect applications that don't allow users to control the names of locals.

Remediation

Upgrade actionview to version 4.2.11.3, 5.0.1 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C
Credit
Unknown
CVE
CVE-2020-8163
CWE
CWE-94
Snyk ID
SNYK-RUBY-ACTIONVIEW-569156
Disclosed
17 May, 2020
Published
17 May, 2020