Improper Input Validation

Affecting twisted package, versions [ ,19.2.1)

Do your applications use this vulnerable package? Test your applications

Overview

Twisted is an event-based network programming and multi-protocol integration framework.

Affected versions of this package are vulnerable to Improper Input Validation due to the package not validating or sanitizing URIs or HTTP methods, this allows an attacker to inject invalid characters such as CRLF.

Remediation

Upgrade Twisted to version 19.2.1 or higher.

References

CVSS Score

7.2
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Credit
Alex Brasetvik
CVE
CVE-2019-12387
CWE
CWE-20
Snyk ID
SNYK-PYTHON-TWISTED-449615
Disclosed
10 Jun, 2019
Published
11 Jun, 2019