Out-of-bounds Read

Affecting pillow package, versions [4.3.0,8.1.0)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Pillow is a PIL (Python Imaging Library) fork.

Affected versions of this package are vulnerable to Out-of-bounds Read. There is a 4 byte read overflow in SGIRleDecode.c, where the code is not correctly checking the offsets and length tables.

Remediation

Upgrade Pillow to version 8.1.0 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Credit
Eric Soroos
CVE
CVE-2020-35655
CWE
CWE-125
Snyk ID
SNYK-PYTHON-PILLOW-1055462
Disclosed
05 Jan, 2021
Published
05 Jan, 2021