Remote Code Execution (RCE)

Affecting studio-42/elfinder package, versions <2.1.58

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

studio-42/elfinder is an open-source file manager for web, written in JavaScript using jQuery UI.

Affected versions of this package are vulnerable to Remote Code Execution (RCE) via execution of PHP code in a .phar file. NOTE: This only applies if the server is configured to parse .phar files as PHP.

Remediation

Upgrade studio-42/elfinder to version 2.1.58 or higher.

References

CVSS Score

8.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Ashok Chand
CVE
CVE-2021-23394
CWE
CWE-94
Snyk ID
SNYK-PHP-STUDIO42ELFINDER-1290554
Disclosed
09 May, 2021
Published
13 Jun, 2021