Cross-site Request Forgery (CSRF)

Affecting phppgadmin/phppgadmin package, versions >=0.0.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phppgadmin/phppgadmin is a web-based administration tool for PostgreSQL. It is perfect for PostgreSQL DBAs, newbies, and hosting services.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). Multiple areas within the application allows sensitive actions to be performed without validating that the request originated from the application. One such area, database.php ​ does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.

Remediation

There is no fixed version for phppgadmin/phppgadmin.

References

CVSS Score

6.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N/E:P/RL:U/RC:C
Credit
Snyk Security Team
CVE
CVE-2019-10784
CWE
CWE-352
Snyk ID
SNYK-PHP-PHPPGADMINPHPPGADMIN-543885
Disclosed
01 Feb, 2020
Published
01 Feb, 2020