Improper Authorization

Affecting moodle/moodle package, versions >=3.10.0-beta, <3.10.2 || >=3.9.0-beta, <3.9.5 || >=3.6.0-beta, <3.8.8 || <3.5.17

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Improper Authorization. When creating a user account, it is possible to verify the account without having access to the verification email link.

Remediation

Upgrade moodle/moodle to version 3.10.2, 3.9.5, 3.8.8, 3.5.17 or higher.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Credit
Unknown
CVE
CVE-2021-20282
CWE
CWE-285
Snyk ID
SNYK-PHP-MOODLEMOODLE-1085983
Disclosed
16 Mar, 2021
Published
16 Mar, 2021