Command Injection

Affecting mikehaertl/php-shellcommand package, versions <1.6.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

mikehaertl/php-shellcommand is an object oriented interface to shell commands

Affected versions of this package are vulnerable to Command Injection. User input is concatenated with a command within addArg() that will be executed without any check.

Remediation

Upgrade mikehaertl/php-shellcommand to version 1.6.1 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Credit
Snyk Security Team
CVE
CVE-2019-10774
CWE
CWE-78
Snyk ID
SNYK-PHP-MIKEHAERTLPHPSHELLCOMMAND-538426
Disclosed
20 Dec, 2019
Published
20 Dec, 2019