Arbitrary Code Execution

Affecting drupal/core package, versions <7.58 || >=8.0, <8.3.9 || >=8.4.0, <8.4.6 || >=8.5.0, <8.5.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

drupal/core is an open source content management platform.

Affected versions of this package are vulnerable to Arbitrary Code Execution. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being completely compromised.

Remediation

Upgrade drupal/core to version 7.58, 8.3.9, 8.4.6, 8.5.1 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H/RL:O/RC:C
Credit
Jasper Mattsson
CVE
CVE-2018-7600
CWE
CWE-94
Snyk ID
SNYK-PHP-DRUPALCORE-72112
Disclosed
29 Mar, 2018
Published
02 Apr, 2018