Improper Input Validation

Affecting urijs package, versions <1.19.4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

urijs is a Javascript library for working with URLs.

Affected versions of this package are vulnerable to Improper Input Validation. The hostname could be spoofed by using a backslash (`)character followed by an at(@)` character.

Remediation

Upgrade urijs to version 1.19.4 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Credit
Alesandro Ortiz
CVE
CVE-2020-26291
CWE
CWE-20
Snyk ID
SNYK-JS-URIJS-1055003
Disclosed
30 Dec, 2020
Published
31 Dec, 2020