Insecure Defaults

Affecting socket.io package, versions <2.4.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

socket.io is a node.js realtime framework server.

Affected versions of this package are vulnerable to Insecure Defaults due to CORS Misconfiguration. All domains are whitelisted by default.

Remediation

Upgrade socket.io to version 2.4.0 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:P/RL:O/RC:C
Credit
ni8walk3r
CVE
CVE-2020-28481
CWE
CWE-453
Snyk ID
SNYK-JS-SOCKETIO-1024859
Disclosed
30 Oct, 2020
Published
07 Jan, 2021