Arbitrary Code Execution

Affecting react-dev-utils package, versions >=1.0.0 <1.0.4 || >=2.0.0 <2.0.2 || >=3.0.0 <3.1.2 || >=4.0.0 <4.2.2 || >=5.0.0 <5.0.2

high severity

Overview

react-dev-utils includes some utilities used by Create React App.

Affected versions of this package are vulnerable to Arbitrary Code Execution. On Windows, developers are allowed to run a local webserver for accepting various commands, including a command to launch an editor. The input to that command was not properly sanitized, allowing an attacker who can make a network request to the server (either via CSRF or by direct request) to execute arbitrary commands on the targeted system.

Remediation

Upgrade react-dev-utils to version 1.0.4, 2.0.2, 3.1.2, 4.2.2, 5.0.2 or higher.

References

Do your applications use this vulnerable package?

Credit
Andrew Clark
CVE
CVE-2018-6342
CWE
CWE-94
Snyk ID
SNYK-JS-REACTDEVUTILS-72875
Disclosed
22 Aug, 2018
Published
02 Jan, 2019