Uncontrolled Recursion

Affecting node-sass package, versions <4.8.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

node-sass is a Node.js bindings package for libsass.

Affected versions of this package are vulnerable to Uncontrolled Recursion. There is a stack consumption vulnerability in the Parser::advanceToNextToken function in parser.cpp in LibSass 3.4.5. A crafted input may lead to remote denial of service. node-sass is affected by this vulnerability due to its bundled usage of libsass.

Remediation

Upgrade node-sass to version 4.8.0 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:U
Credit
Unknown
CVE
CVE-2017-11556
CWE
CWE-674
Snyk ID
SNYK-JS-NODESASS-535503
Disclosed
23 Jul, 2017
Published
25 Nov, 2019