Out-of-bounds Read

Affecting node-sass package, versions <4.11.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

node-sass is a Node.js bindings package for libsass.

Affected versions of this package are vulnerable to Out-of-bounds Read. An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::skip_over_scopes which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service. node-sass is affected by this vulnerability due to its bundled usage of libsass.

Remediation

Upgrade node-sass to version 4.11.0 or higher.

References

CVSS Score

8.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H/E:U/RL:U/RC:U
Credit
Unknown
CVE
CVE-2018-11693
CWE
CWE-125
Snyk ID
SNYK-JS-NODESASS-535501
Disclosed
04 Jun, 2018
Published
25 Nov, 2019