Out-of-bounds Read

Affecting node-sass package, versions <4.2.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

node-sass is a Node.js bindings package for libsass.

Affected versions of this package are vulnerable to Out-of-bounds Read. ]There is a heap-based buffer over-read in the Sass::Prelexer::re_linebreak function in lexer.cpp in LibSass 3.4.5. A crafted input will lead to a remote denial of service attack.

Remediation

Upgrade node-sass to version 4.2.0 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:U/RL:O/RC:U
Credit
Unknown
CVE
CVE-2017-11608
CWE
CWE-125
Snyk ID
SNYK-JS-NODESASS-535499
Disclosed
24 Jul, 2017
Published
25 Nov, 2019