Use After Free

Affecting node-sass package, versions >=4.4.0 <4.13.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

node-sass is a Node.js bindings package for libsass.

Affected versions of this package are vulnerable to Use After Free. A use-after-free vulnerability exists in handle_error() in sass_context.cpp in LibSass 3.4.x and 3.5.x through 3.5.4 that could be leveraged to cause a denial of service (application crash) or possibly unspecified other impact. node-sass is affected by this vulnerability due to its usage of libsass.

Remediation

Upgrade node-sass to version 4.13.1 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:U/RC:R
Credit
Unkown
CVE
CVE-2018-11499
CWE
CWE-416
Snyk ID
SNYK-JS-NODESASS-535497
Disclosed
26 May, 2018
Published
25 Nov, 2019