Improper Authorization

Affecting loopback package, versions >=2.0.0 <2.40.0 || >=3.0.0 <3.22.0

Overview

loopback is a highly-extensible, open-source Node.js framework that enables you to create dynamic end-to-end REST APIs, access data from several databases, incorporate model relationships and access controls for complex APIs, and more.

Affected versions of this package are vulnerable to Improper Authorization. An attacker can create Authentication Tokens on behalf of other users. If the AccessToken model is publicly exposed, the attacker can create tokens for any user as long as they know the target's userId. This will allow the attacker to access the user's data and their privileges.

Remediation

Upgrade loopback to version 2.40.0, 3.22.0 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

7.7
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    Low
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L/RL:O
Credit
zbarbuto
CWE
CWE-287
Snyk ID
SNYK-JS-LOOPBACK-73559
Disclosed
15 Aug, 2018
Published
20 Jan, 2019