Cryptographic Weakness

Affecting jsrsasign package, versions <10.1.13

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

jsrsasign is a free pure JavaScript cryptographic library.

Affected versions of this package are vulnerable to Cryptographic Weakness. Invalid RSA PKCS#1 v1.5 signatures are mistakenly recognized to be valid.

Remediation

Upgrade jsrsasign to version 10.1.13 or higher.

References

CVSS Score

5.9
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Credit
Daniel Yahyazadeh
CVE
CVE-2021-30246
CWE
CWE-521
Snyk ID
SNYK-JS-JSRSASIGN-1244072
Disclosed
08 Apr, 2021
Published
08 Apr, 2021