Authentication Bypass

Affecting http-auth package, versions <3.2.4

Do your applications use this vulnerable package? Test your applications

Overview

http-auth is a package for HTTP basic and digest access authentication.

Affected versions of this package are vulnerable to Authentication Bypass. If a client specifies large nonceCount then this request can be replayed nonceCount - serverNonce[2] times.

Remediation

Upgrade http-auth to version 3.2.4 or higher.

References

CVSS Score

9.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Credit
Dmitry Kochin
CWE
CWE-294
Snyk ID
SNYK-JS-HTTPAUTH-471683
Disclosed
13 Mar, 2019
Published
03 Oct, 2019