Arbitrary Code Execution

Affecting handlebars package, versions >=4.0.0 <4.5.3 || <3.0.8

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

handlebars is an extension to the Mustache templating language.

Affected versions of this package are vulnerable to Arbitrary Code Execution. The package's lookup helper doesn't validate templates correctly, allowing attackers to submit templates that execute arbitrary JavaScript in the system.

Remediation

Upgrade handlebars to version 4.5.3, 3.0.8 or higher.

References

CVSS Score

8.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Changed
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:L
Credit
Francois Lajeunesse-Robert
CWE
CWE-94
Snyk ID
SNYK-JS-HANDLEBARS-534478
Disclosed
14 Nov, 2019
Published
15 Nov, 2019