Access Restriction Bypass

Affecting gatsby-source-wordpress package, versions <4.0.8 || >=5.0.0 <5.9.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

gatsby-source-wordpress is a Source data from WordPress in an efficient and scalable way.

Affected versions of this package are vulnerable to Access Restriction Bypass. It leaks .htaccess HTTP Basic Authentication variables into the app.js bundle during build-time. Users who are not initializing basic authentication credentials in the gatsby-config.js are not affected. A patch has been introduced which mitigates the issue by filtering all variables specified in the auth: { } section.

Remediation

Upgrade gatsby-source-wordpress to version 4.0.8, 5.9.2 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Credit
Unknown
CVE
CVE-2021-32770
CWE
CWE-200
Snyk ID
SNYK-JS-GATSBYSOURCEWORDPRESS-1319669
Disclosed
16 Jul, 2021
Published
16 Jul, 2021