Improper Input Validation

Affecting electron package, versions <10.4.4 || >=12.0.0 <12.0.6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation due to insufficient data validation that exists in V8.

Remediation

Upgrade electron to version 10.4.4, 12.0.6 or higher.

References

CVSS Score

4.8
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:U
Credit
Sergei Glazunov
CVE
CVE-2021-21231
CWE
CWE-20
Snyk ID
SNYK-JS-ELECTRON-1277526
Disclosed
29 Apr, 2021
Published
02 May, 2021