Heap-based Buffer Overflow

Affecting electron package, versions <10.4.4 || >=11.0.0 <11.4.4 || >=12.0.0 <12.0.6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap-based Buffer Overflow via V8.

Remediation

Upgrade electron to version 10.4.4, 11.4.4, 12.0.6 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Credit
Guang Gong
CVE
CVE-2021-21222
CWE
CWE-122
Snyk ID
SNYK-JS-ELECTRON-1277203
Disclosed
28 Apr, 2021
Published
28 Apr, 2021