Insufficient Validation

Affecting electron package, versions <9.4.2 || >=10.0.0 <10.3.1 || >=11.0.0 <11.2.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Insufficient Validation via an unknown issue in chromium.

Remediation

Upgrade electron to version 9.4.2, 10.3.1, 11.2.2 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Unknown
CVE
CVE-2021-21118
CWE
CWE-20
Snyk ID
SNYK-JS-ELECTRON-1070014
Disclosed
03 Feb, 2021
Published
03 Feb, 2021