Improper Input Validation

Affecting electron package, versions >=10.0.0-beta.1 <11.2.1 || <9.4.4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation via the File System API.

Remediation

Upgrade electron to version 11.2.1, 9.4.4 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L/E:P
Credit
Maciej Pulikowski
CVE
CVE-2021-21123 CVE-2021-21129 CVE-2021-21130 CVE-2021-21131 CVE-2021-21141
CWE
CWE-20
Snyk ID
SNYK-JS-ELECTRON-1064555
Disclosed
24 Jan, 2021
Published
24 Jan, 2021