Command Injection

Affecting create-git package, versions <1.0.0-2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

create-git is a generator to initialize a project with git.

Affected versions of this package are vulnerable to Command Injection. User-provided input was not properly sanitised before being used as part of an exec() call.

Remediation

Upgrade create-git to version 1.0.0-2 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
mik317
CWE
CWE-78
Snyk ID
SNYK-JS-CREATEGIT-1022150
Disclosed
26 Oct, 2020
Published
27 Oct, 2020